Netbooting octopi not working

What is the problem?

I am currently trying to boot Octopi off the network. I already do this with RetroPie, and it works great.
The system boots, but it is super sluggish. Even an ls takes time. The RetroPi works better than on SD when booting over the network.

In addition, the server doesn't start - I keep getting the " The OctoPrint server is currently not running", without seing any relevant message on the log files.

What did you already try to solve it?

I thought it could be a network issue - I have tried another cable and another Raspberry Pi 4 (with both 4Gb and 8Gb. Nothing works. System is super sluggish.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I tried to print the dump, it just get stuck and doesn't print anything.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
OctoPrint version : 1.5.2
OctoPi version : 0.18.0
Raspberry Pi 4 8G/4G (tested on both).
Linux octopi 5.4.79-v7l+ #1373 SMP Mon Nov 23 13:27:40 GMT 2020 armv7l

If I install OctoPrint on a clean Raspbian system, will I miss anything? I am almost going that way, as I do prefer to boot off the network instead of using SD cards.

Hello @francisaugusto !

It would be quite helpful if you would share the logs.

Thanks @Ewald_Ikemann !

The logs are below.

Could you please share complete logs (as files) and no snippets.
If they are to large, you can zip them load the up here. (138.5 KB)

Sure, here they are.
One thing I didn't mention: I can't start dphys-swapfile. It always says the swap has holes. I tried to erase it and rebuild it to no avail. I don't know if this is an issue.

OctoPrint getting hung up on Loading plugins in the log file was a bug where there were files that couldn't be loaded properly in /home/pi/.octoprint/plugins. I think it may have existed in 1.5.x, fixed in 1.6.x possibly.

In that case... The steps to try and fix this issue were to delete everything in /home/pi/.octoprint/plugins. If there's nothing there, then I've got this problem wrong, and it will be a different issue. But this definitely was an issue at some point.

There's nothing there. I will install on an SD card to see if it works better. There's just something that is making the system extremly slow when booting off network.

I installed it on the SD card, and it works. Something is off with my network booting. I will try to see what it is. It is not getting some of the configurations.

Ok, now I am lost here. It seems that the /boot partition of an installed OctoPi differs from that of a vanilla Raspbian. That's probably why booting off the net is not working, I see that the boot partition of the install image is different than that of an installed system.

I am not sure if copying an installed system to a tftp/nfs server will work. So I wonder if I could instead install a vanilla Raspbian and install OctoPrint on it - would it be very different than installing OctoPi?

I copied the SD card of an installed instance of OctoPi, and copied the respective partitions to the network. The boot seemed a bit different, but everything seems to work fine! :slight_smile:

1 Like