New Camera Stack - Only one camera works at a time after reboot

Camera model

Logitech C930e
Generic Endoscope camera

What is the problem?

I started from a fresh install of octopi with the new camera stack and restored from a backup of my previous Octopi instance. I then followed the instructions for adding two cameras (first on 8080, second on 8081 with the listen option) and it worked fine... until I rebooted. Upon reboot, I could only get the Logitech camera to work. Tried changing the resolution and format for both cameras, no luck. Then tried restarting the pi with only the other webcam installed and was able to see the other camera. Plugging in the logitech again, I was able to see both cameras. Rebooted a second time with both plugged in, now only the endoscope camera server loads and the logitech stream does not.

What did you already try to solve it?

See above

Have you tried running in safe mode?

Yes (manually access stream via URL shows same problem)

Did running in safe mode solve the problem?


Systeminfo Bundle (120.5 KB)

Additional information about your setup

Octopi on Raspberry Pi 4B, not plugged into 3d printer