"New Firmware Version Available, please upgrade."


#1

What is the problem?
Octoprint has been working well for the last couple months since I installed it.
In the last week or so, shortly after Prusa released their new firmware version 3.4.0, whenever I start a print from Octoprint, the machine beeps and I get the message on my Prusa Mk3 Display
"New firmware version avaliable:
3.4.0
Please upgrade."

The printer will not start with heating or anything until I click the knob on the printer.
The Prusa forums have many posts about problems with this firmware, so I don't really want to upgrade it. None of the features in my opinion justify taking the risk with the working system that I currently have.

Trouble is, I can't seem to find any setting inside octoprint or the printer menus to turn this nag screen off.

Is it possible to disable this function and if so, how?

What did you already try to solve it?
Tried looking through every setting in Octoprint and the printer itself. I imagine I could have missed it.
I tried printing from the printer's built in SD card. I don't get the warning. So I think this must come from Octoprint.
I tried searching on this forum, the Prusa forum and the web in genereal, but was unable to find a solution.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint Version 1.3.9
OctoPi Version 0.15.0PE
Prusa i3 Mk3
Raspberry Pi Zero W
octoprint.log (10.6 KB)

Thanks for any help!


#2

Hi!

Obviously your printer still runs with FW version 3.1.1:
(Time code 17:17:33,896)

2018-09-24 17:17:23,636 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2018-09-24 17:17:33,712 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2018-09-24 17:17:33,763 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting baudrate" to "Operational"
2018-09-24 17:17:33,798 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2018-09-24 17:17:33,896 - octoprint.util.comm - INFO - Printer reports firmware name "Prusa-Firmware 3.3.1 based on Marlin"
2018-09-24 17:17:33,934 - octoprint.plugins.ipOnConnect - INFO - ipOnConnectPlugin: 192.168.1.8
2018-09-24 17:17:36,006 - octoprint.util.comm - INFO - Printer seems to support the busy protocol, telling it to set the busy interval to our "communicationBusy" timeout - 1s = 2s
2018-09-24 17:17:38,423 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Printing"
2018-09-24 17:17:39,810 - octoprint.util.comm - INFO - M110 detected, setting current line number to 0
2018-09-24 17:17:51,465 - octoprint.util.comm - INFO - Externally triggered heatup detected
2018-09-24 17:27:05,367 - octoprint.server.heartbeat - INFO - Server heartbeat <3

When you use the recent Slic3rPE, it demands FW V 3.4.0
What does the the printer show as firmware? (Menu -> Support -> Firmware version)
Have you just installed the new Slic3r package and missed the firmware update?


#3

Yes, thank you! I didn't even think of the slicer. The latest version(s) will auto-update the various settings...
That explains why printing from the SD card doesn't trigger, those are all old files. (I haven't used it since I got OctoPrint up and running).
OK, I think I figured out where this is coming from. I'll give it a try when the current print finishes.