New High Quality Camera Module. It's not working right. Appreciate advice

SOLVED: SSHing in and updating the software resolved the issue. I followed the steps on this vid:

Makes sense as the latest official Raspbian appeared to work, but OctoPi didn't.

The RPi4 had the latest firmware, but there were plenty of software packages to update.

So, if anyone else has issues, please update everything via apt.



Finally got around to setting up the new hi quality camera module from the raspberry pi foundation w/ a RPi4 which has been happily running octopi for months without missing a beat.

I haven't had a camera hooked up to octoprint or a pi before, so I was excited to see how this would go.

Unfortunately, the results were less than spectacular:

The issue could be (but not limited to) the following:

  • I accidentally bent the ribbon cable a little when I put it together (not tremendously, just a little)
  • I have to change some setting in /boot/octopi.txt
  • The camera module is faulty
  • RPi4 is too hot? I don't have a fan on it, but it's just running octopi, so should it make a difference?

I have a CCTV C-mount lens connected. It's probably way out of focus, but need to fix the issue at hand before I move onto the rest of the troubleshooting.

I simply connected the ribbon cable and here we are.

Also tried changing the settings in boot/octopi.txt to:
camera_raspi_options="-x 1920 -y 1080 -fps 10"

That just seemed to increase the resolution of the strange grey swirls.

I tried removing the lens as from what I've seen, you should get a blank, pink image output. Mine is seriously grey and pixelated.

I've checked the ribbon cable many times. It's facing the right way and is seated properly. Though, I did need a little more force to connect it to the RPi than I expected.

It's definitely picking something up. Those grey blobs are in the rough shape of my 3d printer's bed. Moving the camera shows a change of scenery. Discernible what it is, but there is definitely something there!

Sometimes the grey image flickers away to something with a blur of colours. Hard to capture as it only happens for a split second.

I'm using the official raspberry pi power supply for the pi4.


If we can't come up with anything, next thing is to try another ribbon cable.

I'll also shoot an email to Core Electronics in Australia who I bought this from.

1 Like

I have exactly the same problem with my Pi HQ Camera as well. My one is attached to the Pi 4B 4GB with an original power supply.

What I've tried;

  • Both 6 mm CS-mount lens and 16mm C-mount lens

  • Different parameters on octopi.txt

  • Even different SD cards :slight_smile:

  • When I try it with regular Raspberry Pi OS (32-bit) it works excellent, that's why I believe that you do not need to change the ribbon cable and we should wait for the new version of lovely Octoprint.

The only difference of my case, when I reboot the Pi or make some changes in the settings and turn back to the control screen, the camera works fine for a second and then I lost my clear image again.

Please find below some screenshots from Octoprint (clear and the strange one) and regular OS.


1 Like

Hey there. Thank you for the informative response.

Looks like your grey spaghetti image resembles mine, but with correct focus and better lighting.

Fingers crossed octoprint gets a fix soon.

Would have bought a decent USB cam, but they are sold out everywhere due to covid and WFH.

Look forward to seeing what the hq cam can do.

1 Like

I fiddled with the same issue with my new Pi HQ Cam for two days in OctoPrint.
Works awesome on the desktop using PiCamApp, however.
Took some cool time-lapse images!

But trying to get it to work in OctoPrint was not fun.
I tried everything that you tried.
I even tried disabling all the plugins.
I tried removing all the plugins.
Same spaghetti image each time

What eventually worked for me was to re-flash my SD card and re-install OctoPrint.
No additional plugins have been loaded.

Doing the re-install wasn't a problem since this was a new install of OctoPrint with the new camera anyway.

Sounds like you have a solid working system now, but if you have a spare SD card, give it a try.

My gut tells me there is a plugin that is not playing well with the other kids.


Thanks for the feedback.

I did as you suggested and created a new octopi from scratch on another microsd.

The most basic setup, no plugins.

Unfortunately, the issue persists.

Next thing to try is raspberry pi os, but hopefully I can set that up headless as I don't have the adapter to run displays off of the RPI4.


I booted up Rasbian and via a number of test shots, I realized that I had two separate c to cs lens mount adapters. One was back and one was silver. Not sure if they both came with the camera, or if one came with the lens (pentax cosmicar cctv lens). Not sure.

So, clearly not an issue with the ribbon cable.

Raspian picked up a picture just fine, but now in octopi I have something closer to an image (attached).

Maybe time to try another fresh copy of octopi, again....

Attempted another fresh install of octopi/octoprint to a separate microsd.

Still no dice. It's mostly a pixelated greyscale image as shown before.

It does flash to a regular image for half a second here or there, but 99.9% of the time, it's as you see in my previous post.

So, as snapshots were working within Raspbian, it seems we have an octoprint issue on our hands.

Not sure where to go from here.

1 Like

Hi @fortyhands, thank you so much for your solution, it works for me too :+1:

I followed the steps and the greyscale image is now normal but the image is super blurry. Do you guys have any idea how to fix it ?

This is how it looks:

Hey guys,

I had the same issue on the latest Octoprint img + HQ Camera (as of yesterday, 7/17/2020)

I was only able to fix it by SSH and running

sudo rpi-update

I have no idea what type of side effects this will cause, but I no longer see funky distorted grey video like the screen shots posted above.

@darvida I had that result after upgrading rpi.. Hopefully you are just out of focus and can adjust the focus ring.

Hope that helps someone,

Did you try sudo apt update and sudo apt upgrade before sudo rpi-update?

hi @fortyhands / All,

I know you show that you got your issue solved with following the steps on the video. I did the same steps and more (I think) and still no dice. Here are my steps I've tried.

  1. update the raspberry pi 4 B with the video you added as your solution.

  2. re-flashed a different SD card with the latest octoprint image.

3, I also did the sudo rpi-update as a last resort.

The image that I get from r-pi is absolutely stunning but the image from the octoprint interface is exactly what you show. Is it a problem with the Rpi 4? but why does the image look great if I am looking through the native raspberry pi imager.

Any help would be greatly appreciated.

Just to be sure - you rebooted after the update, right?
You could also try the 64bit nightly

Yes I did the reboot. I typed in sudo reboot right after all the updates/upgrades were performed. I will try til new build tonight and report on the progress.

@PrintedWeezl That new build worked!!!

1 Like