New installation - Octoprint server not currently running (I didn't change the username)

What is the problem?

New installation on an old Pi Model B Rev 2 (I know, but it's what I have)

"The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host= --port=5000

If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versionsas well as your octoprint.log.

What did you already try to solve it?

My result from the suggested command:
pleoctopl:- 5 ps of | grep i octoprint | grep i python

pi 246 T (19:34 7 00:00:20 /home/pi/oprint/bin/python
3 /home/pi/oprint/bin/octoprint serve host= port=5000

pieoctopi:- $ -1.octoprint/logs/octoprint.log

bash: /home/pi/.octoprint/logs/octoprint.log: Permission denied

pi@octopi:- sudo service octoprint restart pi@octop1: sudo poweroff

Log file contents:
2022-11-27 20:05:25,299 - octoprint.startup - INFO - ******************************************************************************
2022-11-27 20:05:25,402 - octoprint.startup - INFO - Starting OctoPrint 1.8.6
2022-11-27 20:05:25,422 - octoprint.startup - INFO - ******************************************************************************
2022-11-27 20:05:26,442 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: online
2022-11-27 20:05:26,666 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to is working
2022-11-27 20:05:26,690 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving is working
2022-11-27 20:05:28,203 - octoprint.plugin.core - INFO - Loading plugins from /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins, /home/pi/.octoprint/plugins and installed plugin packages...

Seems ok??

Have you tried running in safe mode?

Not yet

Did running in safe mode solve the problem?

Is it likely to?

Systeminfo Bundle

Been trying to find it but I can't via sftp. If someone could point out where it lives then I'll grab it.

Octoprint was downloaded and installed as per the instructions on here today so it's the newest versions.

It's a RPi Model B var 2
Octoprint 1.8.6
Octopi 0.18.0

I've tried flashing Octoprint on two different SD cards with the same behaviour.

I didn't change the username from pi :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.