New motherboard won't connect to octoprint

What is the problem?

New motherboard (v4.2.7) won't connect to Ender-3 pro

Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?

tested 5 usb cables (one new and expensive)
Reinstalled Octoprint

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 915722240
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

Additional information about your setup



2021-06-04 15:31:42,441 - octoprint.util.comm - INFO - Changing monitoring state from "Offline" to "Detecting serial connection"
2021-06-04 15:31:42,476 - octoprint.util.comm - INFO - Serial detection: Performing autodetection with 0 port/baudrate candidates: 
2021-06-04 15:31:42,477 - octoprint.util.comm - INFO - Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
2021-06-04 15:31:42,478 - octoprint.util.comm - INFO - Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

I do suspect that the new board has a faulty usb port. My old board had a usb mini, but the new one a usb micro so I had to swap the cable. I tried several and even bought a new 1 meter data cable, but still no connection.

I tried to connect it to my computer, but win 10 doesn't detect anything.

I have taped over the 5v pin.

What else can I do to be sure the board is faulty from the start?

Hi :slight_smile:

It could also be a software problem.
Which firmware are you using on the board?

Does the printer appear in device manager? When you plug the printer into the PC does windows make sound?

It says Marlin 1.0.1, 2020-04-25, Ender-3 Pro

No sound whatever, and nothing pops up in device manager under Universal Serial Bus controllers

Insert a fat32 formated sd card into your motherboard and try it again and if you you already had an sd card in it try it without it.

I had the original sd card in it. I removed it and connected the usb cable to the computer and to the raspberry, but still nothing.

Any drivers I should install manually?

I'm sure I've misunderstood but obviously Octoprint won't run without the SD card, it hold both code and config data.

In this case I think they're talking about the SD card in the printer, not the Pi.

That's how I read it as well :slight_smile:

there is/was a weird sd card related bug on some creality boards which caused usb connection issues.

My last idea would be to check the usb port.
Maybe a pin is bend and prevents a successful connection.

The relevant drivers if you do want to try that are for the CH340 chip, that's what they use on the Creality V4 boards.

Thanks, I installed them but still nothing. I guess that without the drivers it should still go Plong and install them or show Unknown device or so?

I've mailed the seller for a replacement...

Looked for a bent pin, but it seems ok

Yeah Ch340 is fairly common, usually works automatically. Seems like a replacement is on the cards.

Sorry for my confusing posts, I completely misunderstood this thread.

1 Like

Just a FYI if anyone is curious :slight_smile:

The MB was faulty. I got reimbursed and ordered a new one, all is fine now :+1: