New NoIR camera not showing video in octoprint


#1

When I log into Octoprint I click on control no video shows up.
I have connected the camera to the PI.
The camera is the new V2 8mp noir camera on a PI 3 B.
I have enabled the camera in the settings through Putty.
When I click on the test video no video comes up. When I click on the test picture it does take a picture.
Any help would be awesome.


#2

Perhaps the URL for the video stream got messed up. What do you have in the stream URL box? Are you running the octopi image?


#3

Thanks for the reply. Is this what you were asking for?

/webcam/?action=stream


#4

When I connect to the printer all works except for the camera/video


#5

That looks right. What happens when you view mjpg-streamer directly by typing the url in the address bar (you have to add the server address since that is a server relative url):

http://ipaddress/webcam/?action=stream


#6

You can also bypass OctoPrint by using http://:8080


#7

I tried putting the URL with the IP address and didn't work. I also tried adding the:8080 to it and no luck. I also tried 8080 with no IP still no luck.
After all this now the snapshot doesn't work.


#8

I tried
Http:/pi address/webcam/?action=stream
Http:/pi address:8080/webcam/?action=stream
Http:/:8080/webcam/?action=stream


#9

I meant to write IP address not pi address.


#10

How do you tell if the issue is the camera, cable or PI? I have tried 2 different cameras and this recent one directly from Adafruit.
Has anyone connected one of these recently? All the videos I see have a very different looking screen when they Putty into octopi and are from 2016 and 2017, nothing from this year.
Funny to watch the videos and how easy they make it look.


#11

Unfortunately now I am no longer able to Putty into the Pi says the password is wrong.
What can I do next?


#12

Fixed the login issue but still no video.
Gina any chance you could chime in?


#13

Things to check/provide:

  • Does the red LED on the camera come on?
  • Output of cat /etc/octopi_version
  • Output of ps -ef | grep -i mjpg
  • Output of cat /var/log/webcamd.log
  • Output of cat /boot/octopi.txt
  • Screenshot of browser @ http://<piaddress>/webcam/
  • Screenshot of browser @ http://<piaddress>/webcam/?action=stream

Please do all of that and report back the results.


#14

Just as a side note, neither of my raspberry pi camera modules have any sort of LED on them at all. Bought from "rsonline" so I don't think they'd be fakes, but certainly neither of them (one regular, one pi-noir) have an LED that lights up.


#15
  • The red LED on the camera is on.
  • unable to get output of cat /etc/octopi_version
  • output of ps -ef | grep -i mjpg is: tps://pastebin.com/PVqFwX0m"
  • Output of cat /var/log/webcamd.log is: tps://pastebin.com/Qvx7AV"
  • Output of cat /boot/octopi.txt is: tps://pastebin.com/aUmyHbVd"
  • Browser Screenshots: tps://imgur.com/a/ukvGm"

I really hope this helps resovle the issue. I'm using a Pi NoIR camera board from element14 and am having the same issues. Please correct the links with the removed "ht" as new users are only allowed two links per post and this issue is the reason i joined


#16

Err... why? Aren't you running OctoPi?

The output of cat /var/log/webcamd.log doesn't load, claims it's been removed.

Your screenshots sadly aren't what I asked for. Please navigate your browser to http://<piaddress>/webcam/ and http://<piaddress>/webcam/?action=stream and make screenshots of that, NOT the OctoPrint web interface.


#17

I'm sure others are much more experienced to fix this issue. However, might i make a quick suggestion just in case you haven't already tried it and simply power off the Pi, unplug the camera ribbon cable form the board, and then plug it back in and make sure all the pins are fully seated down in the port as far as they will go.

Only suggesting this as i had a similar issue recently when i did my first setup and i found that the ribbon cable had pulled out slightly on one side allowing the LED to come on but not allowing the video stream to be accessed.

Hope this helps, if not, good luck! :slight_smile: