New octopi 0.17.0 install. plugin manager not updating

What is the problem?

i just built an image from download of OctoPi 0.17.0 on a rpi 4/4G and plugin manager is not working. i only get the default plugin in the list, does not show what is in the list at

What did you already try to solve it?

searched forum. also tried to install a plugin manually and that seams to work

Have you tried running in safe mode?


Did running in safe mode solve the problem?

same, no plugins from plugin url

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

octoprint.log (119.8 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
octoprint 1.5.2, octopi 0.17.0, anet a8, stock firmware, raspberry pi4/4g. image from download

I believe your RPi can't access the internet due, most likely, by a failure to find a suitable DNS server (see below).

The log you posted is full of various network related failures but since you have OctoPrint 1.5.2, the network must have worked at some point in the past long enough for it to be downloaded (it
isn't included in the OctoPi 0.17.0 distribution).

Can you login to the RPi over SSH? If so, lets start with posting the output of: ifconfig, iwconfig, and cat /etc/resolv.conf. Please use the </> button in your reply so the output is readable.

2020-12-26 01:59:01,171 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: offline
2020-12-26 01:59:01,172 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to is working
2020-12-26 01:59:01,173 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving is not working

I was thinking that. But when I ssh to the pi, I can ping using dns names and I get reply back from pings

pi@octopi:~$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::84d3:c1bb:f820:55cf prefixlen 64 scopeid 0x20
ether dc:a6:32:21:0a:22 txqueuelen 1000 (Ethernet)
RX packets 1768 bytes 484611 (473.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3437 bytes 4044632 (3.8 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 1679 bytes 4093562 (3.9 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 1679 bytes 4093562 (3.9 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::cd55:a814:ca5:801f prefixlen 64 scopeid 0x20
ether dc:a6:32:21:0a:23 txqueuelen 1000 (Ethernet)
RX packets 395 bytes 41444 (40.4 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 80 bytes 17320 (16.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

pi@octopi:~$ iwconfig
wlan0 IEEE 802.11 ESSID:"Internet"
Mode:Managed Frequency:5.66 GHz Access Point: 5C:5B:35:4D:B2:E1
Bit Rate=200 Mb/s Tx-Power=31 dBm
Retry short limit:7 RTS thr:off Fragment thr:off
Power Management:on
Link Quality=63/70 Signal level=-47 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

lo no wireless extensions.

pi@octopi:~$ cat /etc/resolv.conf

Generated by resolvconf


I'm a bit confused about the apparent intermittent nature of this problem. Do you have anything like Pi-hole installed?

Since you are in a private network and your DNS servers are in (another) private network, we probably need more details about how your network is configured.

Also route, route -n, and traceroute might be useful.

I can get all that later this evening.

This is just the image download from the sight. Nothing added other than the one plugin to check to make sure I was not having connectivity issues.

There is a firewall between the two network. All policies are allowed from this device to the dns servers on the local network. The dns servers are Windows domain controller as well. Dhcp is done from the firewall/router. I’ll check all the policies between the two network. But as I said I installed octopod without any issues direct, since plug-in manager doesn’t work. I also tried using google for dns. There is an any any permit out to the internet. And that give no better results. The dhcp server has a reservation for this device, so same ip every time.

the firewall is permitting dns and ping to and DNS servers)

pi@octopi:~$ route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default UG 202 0 0 eth0 U 202 0 0 eth0

pi@octopi:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface UG 202 0 0 eth0 U 202 0 0 eth0

pi@octopi:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=127 time=1.04 ms
--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 1.039/1.039/1.039/0.000 ms

pi@octopi:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=127 time=1.51 ms
64 bytes from icmp_seq=2 ttl=127 time=1.16 ms
--- ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 3ms
rtt min/avg/max/mdev = 1.156/1.331/1.507/0.179 ms

the network the Pi is on is my IoT network. it does not have access to my internal network, other than dns from my dns servers. these servers use forwarders poing to root servers on the Internet. and support my internal windows domain. there are other devices on the IoT network, these are all working. even my work laptop is on the network. I don't think the issue is with the network, but with this Pi. I have octoprint on a pi0w currently running and was setting this up to replace the pi zero.

as i said previously, i am able to install plugins, but need to do it manually and not through plugin manager. when i do it manually, it still reaches out to git to download the bits.

i am also getting notification of plugin update. but the plugins down show up in plugin manager.

In that case, maybe it is just name resolution of I know it's hosted by GitHub however I don't know where the domain resolution would go first. The updates working implies works fine.

Standard Raspbian distributions out of the box have a broken /etc/nsswitch.conf file. If you edit the file you will see a line like this :
Hosts: files mdms4_minimal [NOTFOUND=return] dns

Note the position of ‘dns’ after the NOTFOUND

This setting means DNS is never used.
Change the line to read
hosts: files dns mdns4_minimal [NOTFOUND=return]

Then dns will work. After a network restart.
One question - why is wired and wifi connected to the same network?

Read this set of posts for more info.

I’ve been running DNS services since 1990 and it’s still HARD.

i had wireless going first only because i came from a pi0w and then figured i could use wired and power the pi off of poe. ive since disconnected from the wireless. both wired and wireless use the same settings for dhcp and dns.

i think dns was working because i could ping using name on devices on the network that i had host records for. also ping host on the internet. ive been running 2 Internet facing name server since 1990 as well. pi's and linux are relatively new to me. the DNS BIND book is the reference book that i use for DNS

making the change in the nsswitch.conf did not resolve the issue. all other items seam to work. i really think there is something wrong with the plugin manager. wouldnt that setting be for mdns and not dns resolution? is there maybe a way to re-install the plugin manager? i also did a full update to get the pi hq camera working

on closer review of rcw88's recommendation, i see that i did not make the changes that were recommended. i have since made the change to /etc/nsswitch.conf and can not ping by host name to the Internet. this still has not resolved my plugin manager issue. but maybe a reboot after the change maybe needed.

when i go to setting-> server and test access to my dns server, i get server is reachable. but when i test name resolution, i get name can not be resolved. but when i ssh to the rpi and ping by hostname, i get name it seams name resolution is not working in octoprint, but is working on the pi

the rpi does name resolution and has access to the internet. octoprint also does name resolution and has access to the internet. plugin manger is still broken. does not update the list of plugins past the default 18. this is after the change recommended by fcw88 and a reboot of the pi

Could you clarify this? I don't know of the default 18 you mention. If it can reach the repository it is either all or none, when you press 'get more' at the bottom.

Sounds like you are getting to the bottom of this, slowly but surely.

these are the ones that are built into the image. sorry 16 plugins as part of the octoprint image

Action Command Notification Support
Action Command Prompt Support
Announcement Plugin
Anonymous Usage Tracking
Application Keys Plugin
Backup & Restore
Core Wizard
Error Tracking
File Check
Firmware Check
GCode Viewer
Pi Support Plugin
Software Update
Virtual Printer

i left it alone and now when i click on get more, i can see the plugins now. woohoo. not sure what the deal, but must have been the nsswitch config issue and then time to refresh and clear some cache somewhere.

Understood, the bundled plugins. Yeah I didn't think there was that many of them... :man_shrugging:

The offline check is not instant, I don't know what it's polling interval is. Good that you got it sorted, enjoy :slightly_smiling_face: