New Octopi install Rasberry Pi 4B: Can't SSH w/Putty

I've configured to wifi connection in the supplicant.txt file and the problem is that I can't connect via SSH with Putty to my Rasberry Pi the first time at the install. I get a public key error after using 'pi' as the login. I've pinged octopi.local in the cmd prompt and tried using the IP address it gives or octopi.local for the Putty session. I've tried octopi 17 and even reflashed with 16 to only get the same result. I've temporarily disabled all Windows firewalls, installed Bonjour, and logged into my router to check any firewall settings there to only find nothing. I've also tried connecting the Pi to my router via ethernet and I get the yellow light but no green light. I'm a newbie to octopi so please go easy on me but getting very frustrated. Thanks for the help.

Please post this error :slight_smile: (screenshot or copy the text)

Don’t have access to screenshot currently but the error is exactly as follows:
No supported authentication methods available (server sent: publickey)
Will try to get screenshot asap. Thanks

finally able to get screenshots. hope this helps

That octopi.local IP that you pinged to (first image) is a public IP address.
Assumingly there is a OctoPi installation near you that was made public.
If I ping my local OctoPi, I get the usual 192.168.nnn,nnn IP address.
I would recommend to connect your Pi via cable and check the router for the correct IP address.

whenever i connect via ethernet i never get the i get the orange light steady on the ethernet jack but never a green light. Also, it never shows a device connected via hardwire as seen in the screenshot above. So, how do I get my IP address?

It seems that the installation is broken.
You should burn it a again. Recommended with Etcher and no formatting.

1 Like

Thanks. This will be the third time. I have a samsung evo sd card. I believe this time I'm going to try a sandisk or kingston. Any other suggestions if I get the same problem?

got sandisk sd card and flashed 17 again. Connected and got running first time. thanks for everyone's help. much appreciated.

1 Like

I install my OctoPi today and hade some issues also.
Couldn't find it thru ssh.
I connect the pi to the tv/screen to see if the pi started. It started and when I logged in to the pi, I hade no connection. (it is possible to see if the pi have an IP adress when you logg-in).
My did not have any adress. So to solve it. I enter the OctoPi configuration by going in - "sudo raspi-config" while connected to the tv.
In the configuration select "Network", then "Wi-Fi" - add your SSID and your password.
See if the problem is solved after that.

Hi @Mr_Chili!

When you had your Pi connected to the TV, you should get the PI's IP address at quite of the end of the listing on the TV screen.

1 Like