New release: 1.9.0

Everyone, it makes me happy to finally introduce you to 1.9.0! This release was originally planned for late 2022 or early 2023, but a sudden rush of security reports and consequently fixes in late summer of 2022 meant focusing on 1.8.x for a while and thus pushing this back. The good thing about this is that a number of new features now made it into 1.9.0 after all which otherwise wouldn’t have been ready to be merged yet!

This is a companion discussion topic for the original entry at

Why does the browser-check page show ES5 as the feature when this page says ES9 is required?

Earlier versions than 1.9.0 had ES5 as the minimum version, the features listed below with 'required since 1.9.0' are the new ES9 stuff, split into their relevant features. Perhaps it should be combined with an 'ES9' sub-heading to make it clear - of course anyone who does not know JS has no idea what the names of the features necessarily mean, and as long as everything is green you are all good.

Adding the ES9 sub-heading would, IMO, go a long way to lessening the confusion I had with that page.

1 Like

Thanks for your hardwork on this!

1 Like

I just installed 1.9.0 with new camera system on my already working pi, now I am getting no video. Do I need additional setup? I am using raspberry pi 3 with raspicam. (33.6 KB)

Strange, I restarted camera system and it works now
sudo systemctl restart camera-streamer

also there was nothing in the log to show an error:

-- Journal begins at Wed 2022-09-21 17:23:40 PDT, ends at Thu 2023-05-25 08:36:01 PDT. --
Sep 21 17:24:30 octopi-mk25s systemd[1]: Starting camera-streamer...
Sep 21 17:24:30 octopi-mk25s camera-streamer-control[680]: Running start for camera-streamer-libcamera.service...
Sep 21 17:24:30 octopi-mk25s camera-streamer-control[680]: ... done.
Sep 21 17:24:30 octopi-mk25s camera-streamer-control[680]: Adding path unit for autolaunch of camera-streamer-usb@default
Sep 21 17:24:32 octopi-mk25s camera-streamer-control[680]: Running start for camera-streamer-usb-default.path...
Sep 21 17:24:32 octopi-mk25s camera-streamer-control[680]: ... done.
Sep 21 17:24:32 octopi-mk25s systemd[1]: Finished camera-streamer.

It's probably easier for you to open your own 'Get Help' topic than to try and troubleshoot the issue here - it looks like you've also installed a brand new OctoPi image (to test out the new camera stack), so the issue might not be related to the 1.9.0 release specifically.

I thought I read somewhere that 1.9.0 should be compatible with Python 3.11, but I discovered it isn't. Is there a timescale to release a version which is?

That's... not intentional. It should be, and the last time I checked it (and actually 1.8.6) was. If you are finding errors running under Python 3.11, please open a topic here or a bug report.

OK, I initially tried upgrading Python from 3.9.2 to 3.11 while running 1.8.something and it failed, so I downgraded Python to 3.9.2 and everything worked again. I then upgraded to 1.9.0rc6 then 1.9.0 when it was released and finally tried upgrading to Python 3.11 at which point OctoPrint wouldn't start and I get:

ImportError: cannot import name 'formatargspec' from 'inspect' (/usr/lib/python3.11/ the error log. So I downgrade Python to 3.9.2 and everything works again!

I can try upgrading Python again, but suspect it will just break and I'll have to downgrade.

I updated to 1.9 and now each time I try to print, it fails to go through the bed leveling and it disconnects. Restarted with the same results. Not sure what to do.

Hello @Jacob_Turner !

Please open a new Get Help thread and fill in the requested information.

I don't know what went wrong this time.
I activated the upgrade via Octoprint and It worked with no errors and no issue with the camera. Thanks this was the easiest upgrade yet.
My setup is
The snappy web interface for your 3D printer Version 1.9.0
The ready-to-go Raspberry Pi image with OctoPrint Version 0.18.0, running on Raspberry Pi 4 Model B Rev 1.5
Thanks to all the people who made this happen.

Hello @Ozemate !

If you need help, please open a new thread in Get Help and provide all requested information.

Not sure why you point me to help when I advised all OK and said Thanks

1 Like

Sorry, I misunderstood because of the first line.

That's ok was a bit on the Funny side I tried to make it. but this was the easest upgrade yet


I personally hate to post something like this but I went from perfectly working Octoprint servers on the old version to a ball of bugs on the new version. Too many problems to even list. I have one install that was updated to the latest version and another that blew up and was reimaged using the latest pi imager and I'm sorry... but nothing but issues with both and unfortunately I don't have time to chase down all these bugs to make things work. Thinking this should have stayed as a release candidate for a few more months.

It was rc for 3 month's and it doesn't magically become bug free because it stays in rc.
We need people to report bugs.
And the fact that you not even list one of those uncountable bugs you encountered doesn't help at all.
If you want something to change or get fixed you have to report what doesn't work, because it obviously works on our end. That's why it has been released as stable.


hi everyone, first of all, thanks for the great work. Last week I updated to the new release and ever since, I can barely have a print finished. Prints are being halted on a temperature base. Sometimes is the bed, sometimes the nozzle. Using Pi 3B+ and a Anet A8 printer. Before this release I've never had a problem like this so I'm guessing is about the release. Any other person reporting this ?