New Router, No OctoPi(s)

I'm fairly certain this is a Windows 10 problem, not an Octoprint issue but I'm hoping there's expertise here that has seen this before. I got a new router over the weekend (ASUS RT-AC86U); All router settings were duplicated to the best of my ability from the old router. I have three previously working printers running Klipper FW wirelessly connected on the network; the SSID and PW were duplicated on the new router. All other devices on the network (wired and wireless) are working properly, however I can no longer get to any of my three printers running Octoprint from my windows PC using the 'hostname.local' method and Chrome as a browser.

I can connect from the PC with a wired ethernet connection to the printer's Pi
I can connect wirelessly with my iPhone 7 using Safari
I can connect wirelessly by typing in the IP address
I see the printer host names on the router's client list, they have different IP addresses than before
If I change the hostname and reboot everything I can connect wirelessly using hostname.local (I'm hoping to avoid changing everything to a new name)

This seems like Windows isn't being flexible to adapt the Pi hostname to the new IP address but I can't figure out how to get it to updated the mapping.

What did you already try to solve it?
Multiple reboots of everything
sudo rasp-config and made sure wifi info was correct and rebooted; changed host name temporarily
Tried DNS flush on Windows PC
Modify Windows hosts file to map hostname.local to IP address I see on router's client list
DHCP release/renew

Logs (5.5 KB)

See attached

Additional information about your network
See Problem

Hello @Krrazy

You can upload the logs as zipped files :wink:

And if you please format the log you shared her with </>

It is way more easy to read.

You may need the Bonjour tool.

Thank you, this was my first post and I wasn't familiar with the editor! I see all of the options now.

I have iTunes on the PC and it worked before getting a new router...not sure is a missing Bonjour thing.

This is a shot into the dark as I'm off win* for some years now so I cannot test it. (Ok, I could start a vm and try to simulate, but too lazy)

open a cmd window
ipconfig /flushdns

Thank you, appreciate the help. That's what I did when I said "Tried DNS flush on Windows PC" has to be something like that though!

mdns is a service you can stop, restart but it's doubtful that will help.

I saw a post with a very similar description, cache - Bonjour seems to cause hostname to resolve to old IP - Super User In that case the poster found a problem with one of the devices

Clear the cache in Chrome

Thank you -- that appears to have been the trick I needed and I'm not connected with all three printers again. I did also reboot my router so sorry to skew the scientific method by changing two variables.

If this happens to anyone else...I did all of the stuff in the original post to no avail. Cleared the Chrome cache as follows:

Upper Right Section of Chrome Window: Click == More Tools>Clear Browsing Data>Time Range: All Time; check History, Cookies, Cached Images and Files

After doing that, then rebooting router (may be unrelated) and closing Chrome and restarting I was able to connect to all printers using hostname.local

1 Like