New Setup, Layer Shifting Benchy at same position each time

What is the problem?

Just got a new Pi 4 and set it up with octoprint this week.

My Ender 3 hasn't encountered layer shifting before this but it seems to be shifting at the same position each time I try to print benchy.

What did you already try to solve it?

I searched the forum and found that maybe changing interval polling could help so I tried that, It didn't work, I also made sure all my belts were tensioned properly and that nothing was skipping (even though prints before octoprint were fine). for the second attempt I tried disabling octolapse with no luck. Finally I turned on safe mode and enabled serial.log and the same problem happened a third time which is when I decided to come ask for help.

Have you tried running in safe mode?

Yep, my last attempt was with safemode

Did running in safe mode solve the problem?

Sadly it did not :confused:

Complete Logs


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint Version: 1.5.3
Raspberry Pi 4 Model B - 4GB
Plugins: Just Octolapse
Printer: Ender 3 Pro
Slicer: Ultimaker Cura 4.8.0
Brave Browser on Windows 10

This is a fresh installation of Octoprint on a brand new Pi 4 (my first foray into Pi tinkering) so I'm hoping this is just something dumb I missed in the initial setup. Thanks for making it all the way down this post! I hope I shared enough info because I'm totally stuck and really need the help.

I guess on the bright side, I have two convertible Benchys if anyone wants one

Do you know whether the printer got a 8bit or a 32bit mainboard?

I tried looking through the spec sheet and couldn't find anything about the board but through a few google searches It seems that if my printer has Mini USB instead of Micro USB it's on the old 8bit board.

Another post said the new 32bit boards started shipping last August and I bought this printer well over a year ago now.

I think it's the 8bit mainboard?

There is a known hardware bug on the 32 bit board(s) but with the 8bit we can rule that out.

I'm not sure in which orientation you printed the benchy and which axis shifted. I I guess it was the Y axis?
You could increase the vref voltage for Y if it's too low

Here is a video that explains how to check the vref voltage

(don't do that psu thing just the vref voltage)

Also I need to know if you got a "silent" 8 bit mainboard or the the older one that let's the printer play chiptunes while printing :wink:

With an increased vref the motor got more torque and doesn't skip steps anymore.

1 Like

So glad I had a multimeter handy, this is the first time I've seen the insides of this machine. Also you are correct, it does seem that it's the Y that skipped.

It would seem that X Y and Z were all at about .46 and I pushed them all to just slightly past .7

Extruder was already at .7 so I left it alone though it seems I could possibly bump that up as well?

I went ahead and took a picture of the board itself too

I don't think it's the chiptune board because this printer seems much quieter than my last (monoprice) but do you know how I could identify that?

Thanks so much for your help this far!

Okay so after altering the vref voltage I sent the same gcode to print and this time it didn't layer shift!

It did however slightly bulge from all sides at the same exact position the layer shift was previously occuring.

Could it still be underpowered? Also do you have any idea why this is surfacing now and why it didn't happen when plugged straight into my PC? Was my PC providing additional power through the usb?

Sry for the late reply

I can't tell you for sure whether it's the silent board or not (because creality released a silent and a normal 1.1.4 board :man_facepalming: ) but if you think the printer doesn't "play music" and is much quieter then I guess it's the silent one.
(You can tell it for sure when you remove one of the coolers on top of stepper drivers and check which ones are installed).

The difference is in the used stepper drivers on the board.
The "noisy" board uses A4988 drivers and the silent board uses TMC2208 drivers.

Here is a calculator for A4988 drivers (use 0.1 Ohm)

and here is a post on how to set the vref on the silent drivers.

0.7 should be a safe value - but keep an eye on the stepper temperatures.
If they are too hot to touch while printing you should lower it again.

And now to the bulge :smiley:
A lot of things could cause it
I would watch the printer when it's printing this layers and check if the extruder skips. (you would hear clicking sounds from the extruder and see the gear jumping back)

No problem at all! I'm just grateful to be getting help at all. This is all still somewhat foreign territory.

I took a look at a comparison video between the noisy and silent one and mine is definitely not the silent one. It's quieter than my old monoprice maker select but still makes what you referred to as chiptune sounds on the first layer.

so it looks like .64 is what I should be aiming for if I used that calculator correctly

if the extruder is skipping on that layer is that also a vref issue? It's strange that all these problems are happening on the same layer.

could also be a hotend problem.
I had a similar problem when I was printing with a lot of retracts.
Turned out that the ptfe tube wasn't all the way down to the nozzle and there was a small gap which was filled with molten plastic.
To fix it I heated up the hotend to idk like 160Β°C, removed the nozzle, pushed the tube through the heatblock and removed the molten plastic blob, pulled the tube back, screwed the nozzle in and loosened it with a half turn, pushed the tube down as far as I could, put the tube fitting fixing ring in and then tightened the nozzle.

Also, just to add an extra point - have you tried moving and re-slicing the model? The bulge/layer shift looks as if it is in the same place each time, which could say it's an issue with the model/gcode. A different position or model would produce a different slice so you can try it.

1 Like

Stab in the dark, something mechanical, something rubbing on something?

I like @Charlie_Powell's suggestion. Re-slice with moving, rotating, and/or scaling. Maybe a different layer height. Rotating 45 degrees would be interesting.

Thanks for the suggestions everyone, Yeah I was hesitant to re-slice right away as I wanted to keep that gcode as a control.

It looks like upping the vref was the solution, I'll keep tinkering to improve the print quality, clearing out the nozzle and reslicing. but I'll mark the solution for anyone else in my situation.

Thanks a ton @PrintedWeezl and everyone else!!