New to OctoPrint - Can't access Octoprint but can ping IP

Think I found the culprit!

So after tons of trying different approaches all to failure... I tried to unplug the camera. Bingo works fine??? I am not using the genuine CP camera its is this:

I never would have suspected the camera to be the cause?

What is the problem?

I have a Prusa MK3 that I have installed an RP ZeroW in. I have followed multiple different sources attempting many different installs of the Octoprint to come to the same conclusion every time. I get the " The OctoPrint server is currently not running" error page.

Initially, the very first set up all went fine... then in the octoprint UI I clicked update and that was it. Since then I can not access it.

What did you already try to solve it?

I have tried connecting to two different routers in my home.
I have tried different versions of octoprint
I have tried setting a static IP

just turned on Apache as I am on a mac I seem to be able to access
Ironically I can SSH into the RP, I can also ping the IP. Totally lost. I have read tons of articles watched every youtube video I would LOVE any Help

Complete Logs

where do I access the logs?

Additional information about your setup

I am using an EERO mesh WIFI, I am able to see the Octopi and its IP on the network.

hi :slight_smile:

first of all - it is advised against the use of a Pi Zero. Something like a Pi 3+ would be a good choice.

Just click on the word logs for further information :slight_smile:

Thank you for the reply... I am fully aware that RP Zero, “is not recommended.” Have you considered the notion that one of the most common printers is in fact a Prusa that was made to easily accept an RP Zero? There are countless people using these with octoprint. Have a wonderful day :slight_smile:

Hey, we're trying our best to help you here, I would consider your statement to be a little.... misguided shall we say. We of course know that it is an option.

You're in the OctoPrint forum - the Pi 0 W is not recommended by the people here.

Prusa decided to make their printer's compatible with a Pi 0, despite warnings, so you should take that up with them.

1 Like

I believe the OctoPrint folks have communicated with the Prusa folks that the RP Zero is marginal at best. Not much more can be done except keep spreading the word that the RP Zero is not recommended by OctoPrint. If it works for you, great. If not, then you know why.

1 Like

Yep thanks Brad exactly I myself am one of those people. I do appreciate the feedback here I was not pointing fingers. As I stated I posed a concept? I think octoprint is amazing I just want to get it working is all. So I appreciate the empathy. Maybe time to get a different pi.

Also why is the zero not recommended?

Because using wifi on the zero, is hard for it. It takes up a lot of processing power to stream a webcam, and as a result for many people with webcams it negatively impacted print quality. And then they come here, to ask us how to fix it...

You can see more about the issues encountered in the ticket from here:

It's mostly an issue with the inbuilt wifi chip, I guess maybe (don't hold me to this, not an expert by any means) that to get the cost of the inbuilt wifi down, it offloads most of the processing to the CPU. Then, only having a single core, means it gobbles all the CPU cycles, leaving nothing for OctoPrint.

edit: and my issue with the statement came from people saying that OctoPrint should work with a Pi 0, because Prusa said so - some people strongly side with them, and it creates frustrations. Apologies if it was misinterpreted.

Charlie thank you so much for the time you took to write that. I’m sure these forms can become quite a headache at points and I don’t wanna be one of those people that’s adding to that. I sincerely appreciate folks like yourself that have the knowledge to help people like me that are not as deeply educated in the space. So if I want to get out to print up and running in a sustainable fashion what raspberry pie would you recommend?

Pi 3B+ if it is cheaper that a Pi 4, is generally what I say. And with Pi 4, only the base RAM model (2GB) is more than enough.