New to printing and octoprint. Homing iusse after setting up Octoprint

What is the problem?

Connected my ender 3 pro with bl touch to Octoprint. When trying to home x/y from octoprint it homes the x fine, but then gives firmware error in octoprint and a homing failed: printer halted please reset on the printer. Upon initializing the homing it make a weird hum noise then proceeds to home the x, then when it tries to home the y it makes the hum again and faults out.

What did you already try to solve it?

reset octoprint numerous times, ran in safe ,mode, disconnected the pi and it homes just fine.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (31.3 KB)

Ender 3 Pro
Octopi V0.18.0
Octioprint V1.7.3
Marlin V2.0.1
BL Touch V1.1.2


Hi :slight_smile:

Some creality boards got an sd card related bug.
Let's try to rule that out first:
If you have no sd card inserted into your printer put one in and vise versa.

Try again and let us know if something changed :crossed_fingers:

You also may try

G28 X Y

instead of

G28 X0 Y0

attempted to home without the sd card inserted and got the same result. also tried to home using manually input G code as suggested below with the same result.

Did you use G28 X0 Y0 or G28 X Y?

i tried G28 X Y

Do you hear the end stops clicking when the X/Y axis reach that point? (Assuming you have mechanical end stop switches.

the x axis will home and click upon reaching its stop, but as soon as it tries to home the y it makes a weird sound and doesnt even attempt to move the carriage then it faults out. ill attach pictures of the faults that i screenshot. since im a new user ill have to post the pics in 2 separate comments

I assume the y carriage does not activate the end stop switch.

Turn of the printer.
Locate the Y end stop switch.
Slowly move the bed to that point and see if there maybe is a misalignment.

if i disconnect the pi and just run the printer by itself it will home and run just fine. im assuming its something to do with octoprint and the creality firmware not communicating correctly. ill give it a try once my current print finishes.

turns out im just an idiot. for whatever reason when i connected the pi and it powered up the printer it didnt occur to me that i hadnt turned on the power to the psu. the pi had enough power to power up the printer and home the x but failed when homing out the y axis. after turning on the power to the printer it homes just fine and i feel like an absolute dumbass. thanks for your help and sorry for wasting your time. im gonna go hide in the corner for a while now.


My problem is that it's been almost a year and can not get a straight answer as to what firmware to install on the mainboard to make the BL active. Installed the "recommended" version and bricked the ender pro.

So on the new mainboard, it is connected but not actually installed.
Need some straight answers to questions sometimes.

Hello @Chris_Owen !

This thread was about a different issue as you described in your post.

Please open a new thread with filling in the in the template required information.

The more information you give, the more answers you can get.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.