New to this and being told No PIP

What is the problem? I am trying to learn all this, but know very little about Linux, I have Octoprint up and running on my Pi4 which is printing just fine.
But when I go to plugin manager, it says I need PIP, had a search but totally got lost.

What did you already try to solve it?

Had a look in the log, I can see it is mentioned as ok, but from there...

Octoprint v1.3.12

Log attachedoctoprint.log (178.7 KB)

Hi @Blueflare

Pip is the packager manager for python. This mean that you must install pip on your Pi4 connecting to it.

You can find the right command on https://packaging.python.org/guides/installing-using-linux-tools/#installing-pip-setuptools-wheel-with-linux-package-managers for your "linux".

I hope that can help you.

Leo

Leo

Thank you for helping Leo, but I am still stuck.
The page you suggested has options I do not understand, which one do I need?
I tried a few but no success, I attachoctoprint.log (217.2 KB) log again if this helps.

"Two roads diverged in a wood, and I ...
I took the one less traveled by,
And that has made all the difference." ~Robert Frost

One road is to use the full buster image. Install OctoPrint onto that. The other road is to use the lite buster image that already has the print server installed. I took the first road, and the second road using a second SD card.

On my Pi 4, I hosted OctoPrint onto a full buster image. It allows freedom to run the Pi 4 either way, with GUI and all applications, OR if the HDMI monitor, mouse, and keyboard are not present the same Pi 4 will automatically boot and start the print server in a headless networked mode.

Foosel has a nice write-up that is easy to find explaining how to put OctoPrint onto the full buster.

I will write some of what I remember about making the "lite" image work. It is important to start fresh with a completely blank SD card. Then, do this:

Use a PC to download the octopi-buster-lite-0.17.0.zip file.
Use Balena Etcher on Windows to burn the .img file onto an SD card.
Etcher can use the zip file directly.
It will go faster if the .img file is already unzipped.
Install the SD card into a Pi 4 that is not powered.
Pi can be headless later using SSH remotely, but not at first.
Connect Pi to an HDMI monitor input.
Connect Pi to a USB keyboard.
Connect Pi to a USB mouse.
Connect Pi to a wired internet port on the same router providing network to the PC.
Do not use WiFi to connect the Pi to the router, not yet.
Power on the Pi. Allow it to boot.
Do not attempt to use the PC internet browser to access OctoPrint, not yet.
On first run, OctoPrint will initate a wizard.
We want that to happen after we do some important bookkeeping.

Login to the Pi 4 using the local hard-wired Raspberry Pi 4 console.
The first login prompt will not be blue.
At the prompt that says "login" respond pi [Enter].
Default password is raspberry with no punctuation or caps.
New prompt will be blue.
At the blue console prompt, type passwd to change the password.

Raspbian buster lite from this image will connect via SSH, but refuse to authenticate the pi user account if the password for the account remains the default password.

On the PC, login to the router's administration utility using favorite internet browser.
Ask the router to list the IP addresses of all things connected.
Each router can do this differently.
Note the IP for the system with "octopi" name.

Start PuTTY on the PC.
Use PuTTY and the IP address to SSH into the Pi.
Verify that SSH works and allows remotely logging in as the "pi" user.

Fix the pi user account to allow passwordess sudo:
sudo nano /etc/sudoers
Sudo is a text editor.
This edits the "sudoers" file in the "/etc" directory.
Add this line to the end of the file:
pi ALL=(ALL:ALL) NOPASSWD:ALL

If you are new to using the nano text editor, stop and go read about it using Google and study examples before continuing. Use it. Make the modification. Later, after all printing connectivity is working, you can come back and edit this file to turn off passwordless sudo as a security provision. It just makes things easier to switch modes temporarily while doing a lot of configuring.

With the sudoers file modified and saved, install pip:

Why?

Pip is not installed by default.
Pip is needed before running the OctoPrint plugin manager.
The OctoPrint plugin manager will need to install a plugin.

A plugin can be installed to fix an issue with MonoPrice model 15365 connecting.
All of that should be fixed prior to starting the OctoPrint setup wizard via a PC browser.

At the pi@octopi prompt, type this:

sudo apt update
sudo apt install python-pip

Allow this to finish, and then restart the Pi gracefully.

sudo reboot

Now use a PC internet browser to navigate to the OctoPrint server page.
Do this by entering the Pi's IP address as the browser URL.

The OctoPrint user interface page appears, and runs an OctoPrint configuration wizard.
Answer the wizard's many questions by using your printer's manual and specifications.
Suppose you have a MonoPrice model 15365.
I will not write (or remember) all the settings for that printer here.
It is just useful as an example of why we need to have pip already available to allow OctoPrint to install plugins.

In the OctoPrint UI, click the wrench icon for configuring.
Set Serial Port to AUTO.
Set serial connection Baudrate to 115200.
Check Auto-connect to printer on server start.
Check Request exclusive access to the serial port.

Click on "Plugin Manager."
Click "Get More."
In the box for ... from URL enter this link:
https://github.com/OctoPrint/OctoPrint-MalyanConnectionFix/archive/master.zip
Click "Install."
After installation success, click on "Save."

I recommend enabling access control when the wizard asks.
To save time when testing this plugin, I ran the test with access control disabled.
You can do it without access control, in order to exactly duplicate my steps,
and then manually activate access control later after verifying connection success.
It should be OK, and it is safer to start immediately using access control.

Bill Triplett
Blue Heron Scientific, LLC.

1 Like

Hi Bill, Thank you for the extensive help, I did all you suggested but ended up back where i started, Octoprint works fine with my printer, but when I go to settings then Plugin Manager I am still told I have no pip.

From my analysis of your OctoPrint.log, it looks like you do have pip but you have network connection issues.

2020-01-08 14:22:18,745 - octoprint.plugins.announcements - INFO - Looks like we are offline, can't fetch announcements for channel _important from network
2020-01-08 14:22:18,746 - octoprint.plugins.announcements - INFO - Looks like we are offline, can't fetch announcements for channel _releases from network
2020-01-08 14:22:18,747 - octoprint.plugins.announcements - INFO - Looks like we are offline, can't fetch announcements for channel _blog from network
2020-01-08 14:22:18,749 - octoprint.plugins.announcements - INFO - Looks like we are offline, can't fetch announcements for channel _plugins from network
2020-01-08 14:22:18,750 - octoprint.plugins.announcements - INFO - Looks like we are offline, can't fetch announcements for channel _octopi from network
2020-01-08 14:22:18,768 - octoprint.plugins.pluginmanager - INFO - Looks like we are offline, can't fetch repository from network
2020-01-08 14:22:18,769 - octoprint.plugins.pluginmanager - INFO - Looks like we are offline, can't fetch notices from network
2020-01-08 14:22:22,466 - octoprint.util.pip - INFO - Using "/home/pi/oprint/bin/python2 -m pip" as command to invoke pip
2020-01-08 14:22:24,594 - octoprint.util.pip - INFO - pip installs to /home/pi/oprint/lib/python2.7/site-packages/ (writable -> yes), --user flag needed -> no, virtual env -> yes
2020-01-08 14:22:24,594 - octoprint.util.pip - INFO - ==> pip ok -> yes
1 Like

Ok, so how do I fix this? I have no clue

Are you able to ping something like google.com from you pi?
(Log into your pi via ssh)

Hi, Sorry not familiar with this command line stuff, I am right at the beginning of Linux, so at the prompt what do i type and what result should I get?

You enter ping google.com -c 5
and if your pi reaches the internet you should get something like this

PING google.com (216.58.210.14) 56(84) bytes of data.
64 bytes from fra16s07-in-f14.1e100.net (216.58.210.14): icmp_seq=1 ttl=56 time=62.5 ms
64 bytes from fra16s07-in-f14.1e100.net (216.58.210.14): icmp_seq=2 ttl=56 time=63.9 ms
64 bytes from fra16s07-in-f14.1e100.net (216.58.210.14): icmp_seq=3 ttl=56 time=63.8 ms
64 bytes from fra16s07-in-f14.1e100.net (216.58.210.14): icmp_seq=4 ttl=56 time=28.8 ms
64 bytes from fra16s07-in-f14.1e100.net (216.58.210.14): icmp_seq=5 ttl=56 time=28.7 ms

--- google.com ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 10ms
rtt min/avg/max/mdev = 28.691/49.545/63.941/16.984 ms

Yes, that worked, I got back as you show

Ok.
Try to disable the online check or change the ip to 1.1.1.1 (if disabling doesnt work enable it again and change the ip) as seen here, reboot the pi and try again :slight_smile:

That did it! I tried disable connectivity check, but made no difference, then tried 1.1.1.1 and I now have plugin manager.
Do I leave as is now?
Thanks for your help, finally got somewhere thanks to you

Yeah sure :slight_smile:
Happy printing :octopus:

(please mark the thread as solved :slight_smile: )

Sorry , back again, now if I try to install any plugin it says Octoprint is not connected to internet, but I pinged it again and results come back as before?

Damn :confused:
What happens when you click on the test host & port button?

It says the server is reachable

A shot in the dark
Try to change the TTLs to 1 minute

Not seeing the Plugin Configuration page, no doubt its there right in my face....