Newb Error: Trying to use the slicer - Cannot upload .st

I have a brand new CR10S Pro and it is working great. Now I am trying to use OctoPi to slice and print, and am encountering a problem. Simply put, I am trying to upload a .stl file. I go to file manager and try to upload the STL.

The process begins and ends with the following error:

Upload Failed
Could not upload the file. Make sure that it is a value file with one of these extensions: .g, .gco, .gcode

It appears that my instance does not support uploading .stl files. What am I missing? Is there a setting somewhere to enable this?

Thank you!

OctoPrint 1.3.11
OctoPi 0.16.0

The Cura-plugin is no longer bundled wiht Octoprint, so it is senseless to upload .stl files.
If you nevertheless want to use it, please read the release notes:


and also the explanation for the plugin:

After reading this I would suggest to re-think if you really want to slice your files via Octoprint :innocent:

2 Likes

Wow, I somehow missed that. Yes, I agree 100%. It sounds like I am better off relying on alternative slicing options.

Thank you!

There are many slicers available for Windows, Linux, MacOS, and even some that are web-based. IceSL comes to mind.

Let us know what hardware you have available and we can make some recommendations.

Hi,

I am currently playing around Cura. I like it because it runs in Windows and on Linux. Web-based ones seem interesting too. What do you folks like?

PS One issue that I am currently grappling with is that the extruder seems to be too high when printing resulting in the filament not sticking to the surface. We have done all the leveling stuff and so I don't think that it is an issue with my CR10S Pro and am thinking that it either relates to my Cura slice file or Octoprint.... Any ideas?

Cura is a good choice. I primarily use CuraLE (LulzBot Edition) which is Aleph Objects' version optimized for their printers. I have experimented with Ultimaker Cura, slic3r, IceSL, and Pathio which are all free. I have also purchased Simplify 3D and KISSlicer (for dual extruders)

Your problem with the extruder being too high is usually fixed with a Z-offset which is usually a firmware setting. You said the printer "is working great". What does that mean (i.e.what have you printed and how did you get / prepare the files). If you have a .gcode file that printed successfully when the printer was "working great", you should be able to upload that file to OctoPrint and it should print identically.

If you still need to troubleshoot the first layer too high problem, using the Terminal tab in OctoPrint, can you type the command M851 and get a response? How about M115? M503? You can post the output of those commands here.

Another thought... Every slicer needs to know things about the target printer and usually has a set of printers it knows about. An important piece of this information is the "start gcode" and "end gcode".

The CR10S Pro appears to have auto bed levelling and that feature is usually triggered by gcode commands in the "start gcode". If the slicer you are using doesn't have specific support for the CR10S Pro then it may be that the "start gcode" isn't exactly what is needed by the CR10S Pro. That could be the cause of your extruder too high issue.

I had the issue only able to upload pre-silced gcode.

I know there is a Plug-in to a slicer, but I worry about settings in that

It's not a defect, it's a feature (the Cura engine was removed since few people used it).

1 Like

Hi all,

So I have made significant progress on this. Let me answer some of the questions from above:

  1. What printed great? The printer came with three sample prints and they were perfect when run from the SDcard. I have not tested them printing through OctoPrint and need to do that.
  2. Test prints from Thingiverse failed as did a custom designed object. All with the same problem
  3. I am using Cura with a CR10s Pro profile that came with it.

Current working solution:
I connected with some folks on a discord board about the situation, and they asked for the header Gcode from the sample file. They reviewed and suggested that I replaced the header GCode in the Cura output with a subset that they provided from the sample print. I did this manually using a text editor. Voila! It worked and has performed well on 2 prints.

Future:
Step 1:
I am trying to solve one problem at a time. All of the above was setup printing from the SDCard directly without OctoPrint. I need to test out printing straight from OP with the fixed gcode files. I assume that it should work.

Step 2:
Cura has a custom gcode header section, and I put the fixed header code in there. Interestingly, Cura adds more GCode into the resulting gcode output, and I am not sure why those lines are there and what they do. I need to understand if these changes hurt the print and so want to test that too. (I currently just delete the added lines with my text editor.)

This has been a lengthy process, and I appreciate everyone's advice. Things seem to be working now, and I am keeping my fingers crossed. I am happy to post the CR10S Pro gcode header if others thing that it would be helpful.

Thank you!

On a side note, I love that gcode files are really text files! It makes things soo much easier.

As I think about, I bet that someone could use the CR10s Pro header gcode and so why not share it for future use. Here is what I am using, and it is based on the gcode from the Creality sample files.

G21        ;metric values
G90        ;absolute positioning
M82        ;set extruder to absolute mode
M107       ;start with the fan off
G28 X0 Y0  ;move X/Y to min endstops
G28 Z0     ;move Z to min endstops
G1 Z15.0 F3600 ;move the platform down 15mm
G92 E0                  ;zero the extruded length
G1 F200 E3              ;extrude 3mm of feed stock
G92 E0                  ;zero the extruded length again
G1 F3600
;Put printing message on LCD screen
M117 Printing...

If I read the documentation for the CR10s Pro correctly, it has auto bed leveling. For my LulzBot TAZ 6 printer, there's a G29 command just after the G28 commands to activate the auto bed leveling process implemented in the firmware. I'd expect a G29 in your header gcode as well.

If, on the other hand, the auto bed leveling process is initiated manually, then a G29 is probably not needed.

That is a good question. I debated this. The Pro does have automated bed leveling, and I decided that I would initiate it manually as needed. Part of the reason I chose this is that Creality does not seem to include G29 in their sample which makes me think that that Creality thinks that it is unnecessary to run this with every print. I will keep an eye on it and will consider adding it in the future.

Thank you.

You have a higher regard for Creality than I have (based on this and other conversations with owners).

With my LulzBot TAZ 6 I got the hardware and an instruction manual that included a pointer to slicing software (CuraLE) that had support for my specific printer model. I also got the phone number (and email address) of 24x7 support with real people answering the phones.

Yes, I paid more for my printer than you did but shoving a few pre-sliced gcode files from an SD card and calling it a success isn't what I'd call acceptable supporting material.

Fair point. It is all about the trade-off. To be clear, I agonized over this purchase for that exact reason. The big question was the trade-off of supporting material/phone support vs budget.

There is no doubt that yours is better supported, but it costs 4x more. That said, Creality should have better material and support than they do.

One of the reason I went with this unit was due to the strong community available for Creality devices. That said, it would be nice if I did not need a community. :slight_smile:

Regardless, thank you for your help!

1 Like

These forums are a "strong community" of OctoPrint enthusiasts covering a wide range of printers, but not always "the printer you have". 95% of the issues raised in this thread are "Creality CR10s Pro" specific and while we have tried to help, I'm afraid your issues require a higher level of expertise than we can provide.

Forget OctoPrint for the moment. Plug your printer's USB port into the computer you are slicing on and use the strong community available for Creality devices to get your issues resolved. When that is done, connect your printer to the RPi running OctoPi and OctoPrint and come back here if you need help.

BTW, I agree with you that the Creality community is indeed strong and that they are responsible for making Creality printers a viable product.

Good Luck and I hope you find the answers you need.

1 Like

Hi,

I understand and agree. The good news is that the printer specific issue feels like it has been resolved. I found a great CR10-centric community over on Discord, and they have strong expertise in the CR10 and helped address the problems. I really appreciate your efforts and that of the rest of the folks here, and recognize that this is not the right place for deep CR10 knowledge.

At the time I opened this, I was flummoxed and was not sure where to turn and so thought that this could be an OctoPrint issue. It was clearly not, and at this point, I have no reason to believe that OctoPrint is at fault for anything.

Thank you again for your help. As an aside, I really like OctoPrint and am excited to use it now that I have gotten the other issues resolved.

Don't forget that she's got a tip jar. :wink:

Cura is no longer part of OctoPrint No STL files uploaded only GCode files