Newb stumbling his way through:octoprint server not currently running

What is the problem?

originally problem was not accessing octoprint through the browser but i can ssh and ping the address and going through the forums lead me to not getting logs to pass along and further going through the forums left me with some type of log to post here and since i been away from forums for so long i can't remember how to drop code or anything else needed here

What did you already try to solve it?

followed some links through the community and did make my way to access some type of logs. they are greek to me so i;m still up poo river without a piddle to paddle.

Have you tried running in safe mode?

because it kept starting in safe mode is why i got into this mess. kept failing at startup and i would reboot via sudo but regaining browser is hit and miss with the tendency to miss being the greatest.

Did running in safe mode solve the problem?

i think in the past that the spaghetti detective was causing a hang up so i never tried to figure why i was in safe mode so i just never really messed with anything other than sending models through for prints. then one day i log on and it isn't in safe mode so, yay. but, then, in passing days, it would hang up on later attempts to log on and then go to safe mode on its own. which is where i am now, unable to access in a browser, in safe mode or not.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

pi@cr-10s:~ octoprint systeminfo -bash: octoprint: command not found pi@cr-10s:~ ~/oprint/bin/octoprint systeminfo
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 8228372480
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.version: 1.7.2
systeminfo.generator: cli

pi@cr-10s:~ $ ~/oprint/bin/octoprint systeminfo .
Writing systeminfo bundle to /home/pi/

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

octoprint version: 1.7.2 octopi version: 0.18.0
printer: cr10s
firmware marlin: 2021-9-3
browser: microsoft edge and ios safari
os: windows 10 and ipados 15.1

not so sure about the zip or how to send it

hi :slight_smile:

Download the zip with the help of WinSCP (it's an ssh file browser). It's located at /home/pi/

and you can upload the zip with this button (39.7 KB)

okay, i think i may have unexpectedly discovered my issue. perusing the forums i learned to not enable the GUI. :roll_eyes: yeah, i know now.

also, went through and removed all third party plug ins save octolapse. and hope to add back octoeverywhere to keep tabs remotely and also, it's fun.

thanks @PrintedWeezl for the help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.