No connection at all with Elegoo Neptune 2

Hi there,

I got my first FDM 3d printer (Elegoo Neptune 2 - a clone of a Ender 3 v2 with a 32bit board) a few days ago and wanted to use OctoPrint to put it on steroids :slight_smile: Hope I can get some help here as I'm running out of options. Am confident with the terminal as long as I get proper instructions :angel:

Thanks in advance for your help!

What is the problem?

Printer is not recognized by OctoPrint at all. Tried to connect with the original USB cable.
Error message reads the following:
State: Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?

  1. Used a different USB cable & removed the micro SD card
  2. Flashed and reinstalled OctoPi with OctoPrint from the official website
  3. Started OctoPrint in safe mode
  4. Checked the USB cable
  5. Activated serial logging
  6. Researched in this forum and tried the suggested fix in this thread
  7. Tried different USB ports at the Raspi
  8. Added "/dev/ttyAMA*" as additional serial port (just in case) - no change at all
  9. Signed up for the forum and posted this topic

Have you tried running in safe mode and if so did it solve the issue?

Yes, it did not resolve the issue

Complete [Logs]
See attached
serial (3).log (5.1 KB)

Additional information about your setup
(OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

Using an Elegoo Neptune 2
Raspberry Pi 4 Model B
OctoPrint 1.5.3 with plain vanilla OctoPi 0.18.0
Tried on Chrome and Firefox
Win 10

Hello @dncn4e !

Just this one? You may try different.

Also try to connect to pronterface.

  1. Unplug the USB cable to the printer.
  2. Login to the RPi via SSH (or a keyboard / monitor).
  3. Type sudo dmesg --clear (enter the pi password when prompted).
  4. Plug in the USB cable to the printer.
  5. Type dmesg >dmesg.log.
  6. Show us the (hopefully non-empty) contents of dmesg.log (use cat dmesg.log to look at it).

If the contents of dmesg.log is empty, then try another USB cable and keep trying cables until you see the printer being recognized by the operating system. OctoPrint can't connect to the printer if the operating system (OctoPi) can't see it.

An alternate cable test is to use the USB cable to plugin a cell phone. Use the same experiment as above and you should see a mass storage device appear in the non-empty dmesg.log.

1 Like

Hi Ewald, thanks for your comment. I already checked three different cables (as mentioned in 1.) so I'm pretty shure it's not the cable! Thanks for the hint, tho - that's also the first thing I ask people when they seek for IT help :smiley:

With Creality printers (and heaven forbid, clones of their design), it is not uncommon to try half a dozen cables until you find one that "works with the printer".

1 Like

Hi there - when I put the cable into my Windows10 PC the following shows up in my device manager after plugging-in the cable: USB-SERIAL CH340 (COM3)
So I guess we now verified the cable is not the problem and the USB slot of the printer is also somehow rooting information though.

When hopping on the Raspi and performing the commands you suggested above I end-up with an empty file, no matter which USB port I'm trying to use. I checked with three cables and all end up with nothing in the dmesg.log.

I checked online if there is a need for installing drivers for raspian (link to YT tutorial) but apparently they're already included in the current release of raspian.

So now we know why OctoPrint doesn't see the printer. It is because the operating system (OctoPi) doesn't see it.

Do you have a USB flash drive? Do you have a cell phone that uses the same micro USB connector as the printer? Use either one or both to verify that each port on the RPi is working.

Does the printer have an LCD screen? With the printer turned off does the screen light up when you plug the cable into your Windows 10 PC? If so, this is called backpowering and there is a topic here that discusses what needs to be done to prevent it. This could also cause the RPi to fail to detect the printer.

1 Like

Thanks for walking me though the troubleshooting! Your point with checking all connectors pointed me towards the solution:

I changed the Raspberry Pi to another model and gave it a clean install - and my printer was recognized right away! Seems like I have a corrupted Raspberry Pi :slightly_frowning_face:

Thank you so much, I owe you a coffee!

For the record: the printer got an USB 2.0 Type B port and there is no backpowering.

1 Like