No Connection to Sidewinder X1

What is the problem?

Octoprint (on a Pi) didn't recognize the Sidewinder X1 Printer.
It worked for years - and then from one day to the other it didn't work anymore.
Connection to Pronterface is possible.

What did you already try to solve it?

tried to change several configurations in serial connection Tab.
Reinstalled a fresh octopi

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/17.4.1 Safari/605.1.15
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 1908686848
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.3-20231009151442
env.plugins.pi_support.octopiuptodate_build_short: 2023.10.09.151442
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.3
systeminfo.generated: 2024-04-17T14:48:58Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

See above
Printer is an Artillery Sidewinder x1 v4

Hello @Dr3D !

Please attach the systeminfo bundle to your next post.

Please also try different USB cables.

Hello Ewald_Ikemann,

I tried different USB Cables. Printerconnection works with Pronterface.
SysteminfoBundle is attached. (901.6 KB)

In the octoprint.log I can't see any usual attempt of OctoPrint to connect the printer. It just runs idle.

ok what does that mean? what can I do that it connects properly?
It's a fresh install.

That means: OctoPrint does not try to connect to the printer.

Have you already clicked the "Connect" button?


I can't do this. I just have the disconnect button.
It doesn't matter what I configure in the Serial Port tab. I tried both Autoconnect on and off.

If you have that, you have connection.

sadly no. No Temperature is shown / I can't print / I can't choose different Baudrates

Are you by chance using Klipper?

I would suggest enabling the serial.log (click blue link for instructions) and the uploading another systeminfo bundle. This should show us the communication details and hopefully why you have a "Disconnect" button instead of a "Connect" button.

You say that Pronterface works so could you provide a screenshot of that when it is connected to your printer? Send the following commands and then another screenshot.

  1. M503
  2. G28
  3. M109 S50
  4. M190 S40
  5. M105
  6. M109 S0
  7. M190 S0

Hello b-morgen

attached the (2.8 MB)

and the Screenshots

Bildschirmfoto 2024-04-18 um 22.53.05

no, I don't use Klipper

Once connected, the left side of the pronterface window shows the port and baud rate that was used to connect.

From the bundle you provided: Performing autodetection with 0 port/baudrate candidates: indicates that OctoPrint isn't finding your printer because it doesn't have a list of ports or baud rates to try. I don't recognize /dev/tty.BLTH as a serial port on OctoPi 1.0.0 so maybe OctoPrint doesn't either.

Moving on to the commands you sent to the printer...

I'll assume the G28 did work.

The M109 (hotend) worked but M190 (bed) did not. Does this printer have a heated bed?

I believe the only issue we need to solve is the lack of choices for the serial port. Under OctoPrint Settings, Serial Connection, Additional serial ports you should add /dev/tty.BLTH if that is indeed the serial port that pronterface is successfully connecting to. The baud rate looks "normal" so that shouldn't need any changes.

and here you go :slight_smile: Thank you very much
Adding /dev/tty to the additional Serial Ports solved the Problem

greetings from Hamburg Germany

1 Like

In the meantime I had the same error again.
When I just restart Octoprint not the whole RPI it works again - I don't know why but this is my workaround.

Strange is that when something is printing and I switch on Octopi it ends up in a mess. The print stops then the printing head drives all the way to the right but ignores the end stop - that makes a terrible noise and is for sure not god for the printer.
I also recognize always the same error on my printers Display (M20 or) M28.