No /etc/default/octoprint

What is the problem?

i am trying to install octopi on a rapsberry pi 4 8GB, that i saw is not officially supported. i need to edit the /etc/default/octoprint script, but i am not able to find it in any way. i can't seem to find even the /etc/intit.d/octoprint script.

What did you already try to solve it?

i tried to look on my already working octopi on a raspberri pi 3b+, and the scripts are where they are supposed to be

Have you tried running in safe mode and if so did it solve the issue?

yes, it did not help.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

i am not sure which logs i should be posting here to help troubleshooting but the systemctl status octoprint returns:

● octoprint.service - The snappy web interface for your 3D printer
   Loaded: loaded (/etc/systemd/system/octoprint.service; enabled; vendor preset: enabled)
   Active: active (running) since Thu 2020-12-03 21:46:48 GMT; 35min ago
 Main PID: 357 (octoprint)
    Tasks: 11 (limit: 4915)
   CGroup: /system.slice/octoprint.service
           └─357 /home/pi/oprint/bin/python3 /home/pi/oprint/bin/octoprint serve --host= --port=5000

Dec 03 21:46:54 octopi octoprint[357]: 2020-12-03 21:46:54,363 - octoprint.server.util.watchdog - INFO - ... initial scan done.
Dec 03 21:46:54 octopi octoprint[357]: 2020-12-03 21:46:54,383 - octoprint.server - INFO - Listening on
Dec 03 21:46:54 octopi octoprint[357]: 2020-12-03 21:46:54,433 - octoprint.plugins.pluginmanager - INFO - Loaded plugin repository data from disk, was still valid
Dec 03 21:46:55 octopi octoprint[357]: 2020-12-03 21:46:55,077 - octoprint.util.pip - INFO - Using "/home/pi/oprint/bin/python3 -m pip" as command to invoke pip
Dec 03 21:46:55 octopi octoprint[357]: 2020-12-03 21:46:55,084 - octoprint.util.pip - INFO - pip installs to /home/pi/oprint/lib/python3.7/site-packages (writable -> yes), --user flag needed -> no, virtual env -> yes
Dec 03 21:46:55 octopi octoprint[357]: 2020-12-03 21:46:55,085 - octoprint.util.pip - INFO - ==> pip ok -> yes
Dec 03 21:46:55 octopi octoprint[357]: 2020-12-03 21:46:55,094 - octoprint.plugins.softwareupdate - INFO - Minimum free storage across all update relevant locations is 52.9GB. That is considered sufficient for updating.
Dec 03 21:46:55 octopi octoprint[357]: 2020-12-03 21:46:55,549 - octoprint.plugins.pluginmanager - INFO - Loaded notice data from disk, was still valid
Dec 03 22:01:52 octopi octoprint[357]: 2020-12-03 22:01:52,335 - octoprint.server.heartbeat - INFO - Server heartbeat <3
Dec 03 22:16:52 octopi octoprint[357]: 2020-12-03 22:16:52,337 - octoprint.server.heartbeat - INFO - Server heartbeat <3

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version : 1.4.2
OctoPi version    : 0.18.0

im on a raspberry pi 4 8GB

There is a 0.18rc1 version of OctoPi available, linked on the OctoPrint downloads page, that supports your pi4 and there are both 32 and 64 bit versions that will work for you. I do not recommend the 64 bit version yet, as the OS it's based on is still in beta and buggy from some of the reports I've seen. You can still install the 32 bit version on your pi though and it is stable.

I'll make sure to try today.

I tried, i still can't seem to find the /etc/default/octoprint script. tired both the 32 and the 64 bit versions of the 0.18rc1. when i go into /etc/default/ and i list the directory the result is:

avahi-daemon   dbus          networking          rpi-eeprom-update
bluetooth      fake-hwclock  nfs-common          rsync
bsdmainutils   haproxy       nginx               rsyslog
console-setup  hwclock       nss                 ssh
crda           keyboard      raspberrypi-kernel  triggerhappy
cron           locale        rng-tools           useradd

Why do you need to?

This is the path to your service file

To change the port of the server. I am runnign different servers without haproxy on the same pi, and i need specific ports for each one.

Then use the service file. Whatever you read about that file, it clearly isn't there and the log is telling you precisely where it is.

That would probably be in the config.yaml