No GCode View when Printing via Plugin

What is the problem?

Whenever I print directly to OctoPrint via Cura Plugin, the GCode Viewer doesn't show the layers, plus I have no estimated print time.

What did you already try to solve it?

Npothing that I can think of fixes the problem.

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

see above

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20240220142359.zip (597.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.9.3, Raspberry Pi image with OctoPrint
Version 1.0.0, running on Raspberry Pi 3 Model B Rev 1.2

Printer is a Mingda Magician Pro with Firmware 1.6.7.5, I run Windows 10 and Firefox

Hello @CodeDaiki !

What plugin?

How do you manage to bypass OctoPrint for printing? How does that work?

Usually you upload your file to OctoPrint and OctoPrint does the print.

More notes on the Printer would be helpful.

Using this Plugin:

https://marketplace.ultimaker.com/app/cura/plugins/fieldofview/OctoPrintPlugin

In the systeminfo bundle you've shared, it's showing that files are being transferred to the printer's SD card through OctoPrint. So most likely, your settings in the Cura OctoPrint plugin are to upload to the printer's SD card rather than locally to OctoPrint. For files on the printer's SD, OctoPrint doesn't have the information on the print so the gcode viewer and estimated time etc. are not available.

2 Likes

Gosh, I'm stupid as a loaf of bread. Thank you. I try to change the settings in Cura to not upload to the SD card. Thank you very much.

1 Like