No Network - Vanilla Raspbian works, but OctoPi does not? (Pi 4B 4GB)

I've been trying to get OctoPi working on my new Pi 4B for a few hours now, but no matter what I do it won't pick up network, I've ordered a micro HDMI adapter to try plug in a display to help troubleshoot but until it arrives I'm turning to you guys for help.

After a few attempts I thought the Pi might be toast so I installed vanilla raspbien and it came up over ethernet straight away, I set up WiFi and DC'd the ethernet and it came back up on WiFi. The Pi Works... just not with OctoPi?!

I've tried the following troubleshooting steps;

  • Two different Micro SD cards (8GB and a 128GB)
  • Installing OctoPi to my SD card using Pi Imager
  • Manually flashing using OctoPio 0.18.0 from their website to the SD card using Etcher
  • Setting WiFi SSID/PW in Pi Imager
  • Setting SSID manually using octopi-wpa-supplicant
  • Ignoring WiFi completely and plugging in an Ethernet cable

Video of ACT LEDs flashing here (Google Photos)

Does anybody have any ideas? Thanks in advance.

Thanks for being specific about what you already tried, so we don't have to suggest these things.
Can you also be more specific about what you mean by "it won't pick up network"? Plugging an ethernet cable between the Pi and your router requires no further configuration, so that should "just work" out of the box. What makes you say it does not work? Does your router "see" the Pi when connected via ethernet?

Copying my answer from the Reddit post I found first - it's far easier to debug the problem on this forum than it is to use that website...

From the video of the green LED blinking - does it flash 4 times long and then 4 times short?

If it does - that is the error code for 'unsupported board'. Which would be confusing, but has happened before that they changed something on the board that meant older images didn't boot.

On the RPi OS that is working, can you run cat /proc/cpuinfo and then try and find the revision field, near the bottom. It might be something like c03112. Let me know what it is.

1 Like

Hey,

To clarify the picking up network comment, if I boot in to Raspbien and it's plugged in to ethernet I see the pi on my connected device list of my router, and I can ping the reserved IP I set for it in DHCP, if I boot in to OctoPi, it would have the same mac address so would in theory "just work" and get the same reserved IP but it doesn't appear in connected devices on it's WiFi Mac or the ethernet mac.

The flashing LED's look like unsupported board. Which version of octopi are you flashing? Also, the pi may have older firmware on it. With the raspberrypiOS, on e you boot, dosudo apt update && sudo apt full-upgrade -y && rpi-update then hit enter. When it gets to the rpi-update you will have to hit y
Let it go until it's done then reboot it. Then run
Sudo rpi-eeprom-update -d -a and hit enter. Reboot again for the update to the boot code to be flashed. When it comes back up, sudo shutdown -h now
Then put the octopi 0.18 flashed SD in and boot it up.

1 Like

Brand new Pi 4 B 2GRAM - Tried octopi-0.18.0-1.7.2, octopi-0.18.0-1.7.1, octopi-0.18.0-1.7.0

same result,no wifi connection and also no wire connection, when i installed PI Os no issue with wifi.

Any idea?
Thanks

When you flash OctoPi through the RPi Imager, you should find a section for 'Nightly' images. Please try one of these and see if that works. We've had a number of reports of a new RPi revision that needs a newer image.

Or better yet, try to flash this image, because that is what I hope to roll out as a fix for this issue:

Download the zip file there, unzip, then use the included img to flash via RPi imager.