No ports showing in Octoprint using UART via GPIO on Pi 5

What is the problem?

Octoprint won't show any serial ports, but shows message:
No serial port found, are you sure your printer is physically connected and supported? Try [refreshing](javascript:void(0)) and if that doesn't help please see the FAQ.

These commands through SSH to the Pi 5 give results as follows:
pytho@CTCi3ProB:~ $ ls -l /dev/ttyAMA*
crw-rw---- 1 root dialout 204, 64 Jan 16 17:48 /dev/ttyAMA0
crw-rw---- 1 root dialout 204, 74 Jan 16 17:54 /dev/ttyAMA10

pytho@CTCi3ProB:~ $ ls -l /dev/serial*
lrwxrwxrwx 1 root root 7 Jan 16 17:39 /dev/serial0 -> ttyAMA0

What did you already try to solve it?

I added Additional Serial Ports to Octoprint:
Yet no serial connection works after trying all these ports.
I just get this output in Terminal for each port tried:

Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x7ffed9687610, open=True>(port='/dev/ttyAMA10', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0125
No answer from the printer within the connection timeout, trying another hello
Send: N0 M110 N0125
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Didn't do it.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (327.6 KB)

Additional information about your setup

What kind of hardware precisely, OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I had Octoprint Version 1.9.3 installed on my Raspberry Pi 5 and working over USB connection to BigTreeTech SKR 3 EZ motherboard. I want to change over to using UART via GPIO so made up a cable with crossover on RX and TX, connecting GND/PA9/PA10 on SKR3 to GND/GPIO14/GPIO15 on Pi 5. I used "sudo raspi-config" to turn off serial console but keep serial port active. Config.txt has dtparam=uart0_console=on. Cmdline.txt has console=serial0,115200 console=tty1 root= ...etc.