No progress data from printer Ender 3 V2

What is the problem?

OctoPi only occasionally gets data from the printer (1 out of 10). I see the picture from the camera and the temperature values, but no progress data (time and %). Maybe there is a plugin with fixes that issue but I didn't find one yet.

What did you already try to solve it?

I tried to start the printer before the pi and vice versa. No change. I restarted the web interface or the App (OctoPod 3.11). No change. I read this thread: OctoPi not reading SD card or print progress from Ender 3 (SOLVED) but it is quite old and - to be honest - it sounds too complicated for me.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

MacBook Pro web interface in Safari, App OctoPod 3.11., OctoPi 0.18.0, OctoPrint 1.5.3, Raspberry Pi 3 B+, Printer Ender 3 V2

Are you running the printer from the SD card?

Yes, because I don't know how to send the files via web interface to the printer. The file names which appear there (or in the App) - if these data are transferred - are not the names I gave to my print files.

When printing from the SD card, many stock firmwares are not transparent about what is going on. To work out what exactly is wrong, we would need an enabled serial.log file, however knowing Creality's firmware this probably won't tell me anything else that I don't know.

To print from OctoPrint, there is an upload button in the web interface. This will print from OctoPrint, over the USB connection. This means that OctoPrint is in complete control of the print job, and knows every little detail. However, printing from SD card OctoPrint is not involved in the process, so it won't know what is going on.

If you wanted to flash your own firmware, there are features that can be enabled that makes the printer more communicative with OctoPrint.

Ok, thanks. I managed it to upload a file from OctoPrint and now all data are visible.

1 Like