No real time update whilst printing


What is the problem?
Total newbie here to Octoprint so be gentle. I recently bought a Raspberry Pi 3+ and are trying to run Octoprint. The installation was simple, but when it comes to printing anything, I am not getting any real time upates, such as time left, G code viewer, or even in the terminal. It will work for the 1st 15 seconds or so, but after that, I have to refresh my web browser to get any information.
What did you already try to solve it?
I have tried reinstalling Octopi and buying a new SD card. Also tried using the Printoid app on my Samsung Tablet but that does it too. EVen tried different web browsers on my laptop.
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Running Ocoprint ver 1.3.9, Octopi 0.15, connected to an Anet E10 which is running on TH3D's latest firmware. My computer is a Dell Inspiron 1545 with 3gig ram, Internet connection speed 8mb
octoprint (1).log (588.3 KB)

serial log located@


Also took a short video showing the issue a bit better @


Don't know why the video not showing up. Any suggestions?

Doing another print now and the time it stops showing live updates changes. Firstly it went for around a minute before I had to refresh the screen, the second time it was only 9s. On the plus side, I'm getting live video streams using the time lapse feature, so at least something is working correctly.


Ok so i've got another computer to try out. i bought a refurb desktop pc from ebay. Although it's not the most powerful machine in the world, it's so far performing a lot better than my Dell 1545 laptop, but I'm still having to refresh the webpage to get a live update. if i have octolapse running, the video feed is fine, but when looking at the terminal tab, it will go so about 20 to 30 secs before stopping and forcing me to refresh the page.

i have noticed that when I'm not printing and the printer is just sitting there waiting for a print job, then the terminal will display the temps if both the hotend and the heatbed all day long.

Anyone got any suggestions????



First things first, restart in Safe Mode (see the System menu) and see if it now works. If so, then it was one of your plugins. Also, try it without running a timelapse video and see if that's happier.

It would be nice to know what operating system and browser you are using to access this.


I tried it in safe mode on my Dell laptop and it did the same thing. I'm running Windows 7 64 bit and using Chrome. Also tried Firefox and Opera. I forgot to mention that I also experience the same problem when using my Galaxy Tablet, either through a webpage or using Printoid Premium app



I'm running a Conky interface on my printer's TFT screen (connected to the Raspberry Pi 3B). I've coded it to show the activity of all four cores of the Raspberry. Streaming everything back to the browser is pretty intensive especially when first starting. It then settles down a bit.

Try plugging both your computer and the Raspberry into Ethernet rather than wi-fi and see if this now works. If so, there's something going on with your wi-fi.


Well I can't connect my pc and raspberry pi via ethernet as my router is too fa taway, but what I did today was move my pc and my printer on my desk, and it's suddenly responding a hell of a lot quicker and better. The only thing i can think that was causing the problem was the fact that both were sitting in front of a radiator and the metal was interfering with the wifi signal.



Oh, absolutely. I know that when I try to listen to my Bluetooth headphones anywhere in the vicinity of either chain-link fence or vertical metal bars, it's a total washout.

The verticality of the radiator just absorbs then re-transmits anything that would be a signal.


I actually never would of thought of that to be fair. i have noticed tonight though, that if i leave the webpage open, then it will stop showing me real time progress after a while, but if I open another tab or doing something else and go back to octoprint tab then it's fine. At the end of the day, I can live with it now. I'm hoping that when my wifi gets upgraded to ultimate wifi (which is estimated to be around 1000Mbs. The first of it's kind in the UK) then it will be a whole lot better.



At the moment my wifi is only 8Mbs, so it's slow as F**K


Well I thought I had solved the issue, just by moving my computer but apparently I didn't. The problem kept appearing, so after a little discussion over on the Octoprint facebook group, and a few beers last night lol, I decided to check my what radio signals my devices were using. As it turned out, my pi was connected to 5Ghz but my pc, phone and tablet were all connected to 2.4GHz, so I disabled the 5GHz radio on my router (pretty sure nothing else is connected to it) and when I did a print last night, I got a contant feed back from the terminal without having to constantly refresh the webpage. Also when I tried the Printoid app on my tablet, that too gave me a constant print progress without freezing.

So today I will be putting it through it's paces just to make sure.