No Serial connection with Rpi and btt skr mini e3 V2

What is the problem?

I have a Bigtreetech skr mini E3 v2 and I can’t connect it to octoprint. Octorprint doesn’t find any serial port connnected to my Rpi. It is always saying “ Offline after error
No more candidates to test, and no working port/baudrate combination detected.”

What did you already try to solve it?

I disabled the 5v pin in the cable with tape, I swapped the
#define SERIAL PORT 2
#define SERIAL PORT 2 -1
#define SERIAL PORT -1
#define SERIAL PORT 2 2
In configuration.h and nothing is working. I also tried with my rpi4 but it’s bot working either.

Have you tried running in safe mode?

I haven’t tried running in safe mode. Because I don’t know what is safe mode.

Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (54.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have a creality Ender 3 with an bigtreetech skr mini E3 V2 installed and a Rpi3b

1 Like

Hi @Thejs1234 ,

I am not much of a help... but just want to let you know that I am in EXACTLY the same spot. Have you found a solution so far?
I was thinking of removing the tape on the 5V pin.. just to try it.. but I dont see any reason why it could work, or even why you would want to have that situation.

Im thinking that it might be of a distro upgrade on the octopi side.. but havent had the time to check that yet

I simply connected the SKR mini e3 v2.0 with a USB to the pi, this time without any tape over the 5V line. Note that I did not power up the SKR mini via the power for my printer.
This time a device is being detected, so that is good but now it is stuck on Detecting serial connection. Maybe the under voltage that I am now experiencing has something to do with it... but at least now I know my cable is OK.

Maybe the tape you're using is too thick and the other contacts don't have good connection. This has been reported just a few days ago.

That would be strange... my connections issues started between two sessions. About somewhere last week or so it worked fine, the day after it suddenly had connection issues.

I just checked your suggestion, re-applied the plastic tape and tried connecting. Now I get this message in the terminal of octopi

Performing autodetection with 7 port/baudrate candidates: /dev/ttyACM0@115200, /dev/ttyACM0@250000, /dev/ttyACM0@230400, /dev/ttyACM0@57600, /dev/ttyACM0@38400, /dev/ttyACM0@19200, /dev/ttyACM0@9600

where it loops over those rates unsuccessfully. So no solution yet, but maybe a step closer!


I test out several solutions

  • Tried 5 different cables (both USB 1.0 and USB 2.0)
    Both with and without the power line covered with a piece of electrical tape
  • Tried the newest version of octopi/octoprint
  • Tried an older version..
  • Tried the following software: octopi, repetier, pronterface
    on the following devices: raspberry pi 3, ubuntu 18 laptop, windows 11 laptop
  • Tried updating/resetting the firmware (Marlin) from version 2.0.7 to 2.0.9
  • Tried to install the MapleDriver (as suggested in the manual on my Windows laptop. However.. I couldnt get beyond the Third party software is not signed error. So left it at that.
  • Verified that the LED on the SKR mini e3 v2.0 are OK

Then finally.. a last try with my Windows laptop: the device was found. Tried it with all the software programs.. and I was able to connect and control the printer again!
The Ubuntu 18.04 machine was still unable to connect to it, so I assume the Raspi will have problems as well.

My conclusion would be that Windows has better drivers for the SKR mini 2.0 than my Ubuntu machine.

Did you try to contact Biqu support?

saw that on

Hello! I struggled to get the PI to connect to the printer when I first set up. I tried different usb cables, a couple of different power bricks (all 5v 3amps) for the PI, nothing worked. I also measured the current used by the pi, and it peaked at 600mA so I assumed that 3amps was overkill. I was wrong.
Since so many posts were pointing the power supply, I used my beefy 10A bench PS to power the PI, and everything worked flawless.
So got a better power supply (around $20 on amazon), 5V 10Amps and had no problems since.

TL;DR: Don't trust the regular power brick that comes with the PI, it seems that in some configurations it can create all kind of problems. Get a beefy power supply instead.

I messages them three days ago now. Waiting for response :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.