No Serial Port Found after working on my Ender 3 Pro with SKR mini e3v3

What is the problem?

I took a break from printing and before then everything was working good. I decided to compile my own Marlin 2.1.2 firmware myself. Octoprint worked for a bit and now will not connect to my printer and says "No Serial Port Found"

What did you already try to solve it?

I used 2 different pi 4s with a fresh install of Octoprint. The new board was working for a little and then stopped. As well I flashed my previous firmware on my board which did not fix the issue. My printer connects to my mac just fine when using Pronterface

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Briefly. It was working but then stopped after a few minutes.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint.log (57.7 KB)
serial.log (198 Bytes)
haproxy.log (101.2 KB)
webcamd.log (1.6 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am using an Ender 3 Pro with a SKR mini E3V3.

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True True
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 1909071872
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.5
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.6-20221018093204
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True 2023-02-08T18:23:34Z
octoprint.last_safe_mode.reason: settings
octoprint.safe_mode: True
octoprint.version: 1.8.6
systeminfo.generated: 2023-02-08T18:27:09Z
systeminfo.generator: zipapi

You may try pronterface to connect the printer to your PC.

Oh, you already did. My bad.

It looks like OctoPrint isn't even trying to connect to anything, there are no serial ports tried.

SSH into your pi and see what device the printer is being assigned. You can look at the output of dmesg after plugging it in and turning it on.

If it is a /dev/ttyACM* you will need to add it to the additional serial ports list for OctoPrint to be able to see it:

If it's not showing up as a device at all then you have some sort of hardware issue, with either the cord, the board, etc.

I'll pass it on to @Casey_Monson :wink:

Sorry, wrong reply button :rofl: .

1 Like

I took a look at my dmesg and I could not find anything. Attached is my dmesg.
dmesg.log (212.8 KB)

As well I added the additional serial ports and that did not work.

Based on all those over-current change messages, it looks like your rpi may be damaged or something is shorting out one of the power regulation chips: [Solved] USB not working - Raspberry pi 2 - Raspberry Pi Forums

One post there mentioned cleaning the board got things going again, but most of the info there points to damage caused by hooking up a device that put too much current back into the rpi.

Does the second raspberry pi have these same messages?

Yes, both of them have the same messages.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.