"No serial port found, are you sure your printer is physically connected and supported?" error after installing 1.8

I suppose this isn't so much a request for help as it is meant as help for others. I ran right into this issue after updating to 1.8 -- not only could Octoprint not find a Serial Port, it was rather unhappy and somewhat reluctant to load the web interface unless the Printer had been powered on. Safe Mode yielded the same results. The pop-up suggests checking the FAQ -- though I could find nothing about this in the FAQ!

It took a bit more research before I understood this to be a feature (rather than a bug), and that this is actually under Settings > Serial Connection > Advanced Options > Ignore Empty Ports. Checking that box restored the behavior I was accustomed to.

Might it be worth making this change more obvious? (I haven't been testing the release candidates, and I don't recall reading about this in the changelog,* though it's entirely possible I missed it.)

[ * Sure enough, it’s there — I just didn’t understand what it meant!]

1 Like

The reason for the new alert is because we were getting way more support requests dealing with what you exactly mention, not having a printer connection available to even try to connect to. The change makes it more obvious that the pi doesn't see your printer and you might need to try a different cable that supports data and not just a charge only cable.

1 Like

I understand that, and I certainly see the value in trying to reduce the support burden — though in a situation like this, I have a setup that has been working without issue for several years, and it seems unlikely that I would have an unexpected cable failure or a suddenly incompatible printer!

The FAQ walks through steps to resolve this error — but it doesn’t mention that this small change in the behavior of Octoprint could also be the cause, and that there is a quick solution (albeit one that’s kinda hidden).

Looking forward to testing the new version a bit further today!

I don't understand - the change with the warning is only a warning. It's triggered if you have no serial ports to select, which works in the same way (broadly speaking) that it did before. The 'old' behaviour is that the only port you have is 'AUTO' and people get confused because it then can't detect a printer. So the warning is there so people know why. It doesn't change anything relating to the actual serial port handling.

In my case, it put up an error message just after I had upgraded Octoprint — that led me to wonder if perhaps there had been a problem with the install (I did see an error message, though the process was ultimately successful), or if there was some unexpected software incompatibility, or some other issue I’d have to deal with.

It’s not that I have a problem with the feature, per se, but I suggest that it would be helpful if this kind of situation (upgrade to an existing setup, not likely to be indicative of a hardware failure) were covered more clearly in the resources that have been prepared for help.

I wonder if you can arrange so you do not have this error message appear every 20 seconds, I know that my printer is "offline" and that OctoPrint can not connect to the serial port, this is a deliberate measure as I do not have my printers turned on if I do not prints, but on the other hand I can work with OctoPrint for e.g. post queue jobs for upcoming runs. These alerts are extremely disturbing even if it's just a warning ............ as I'm 100% aware of why you made this change, but how can you turn off that they are going anywhere 20 seconds

Checking the box at Settings > Serial Connection > Advanced Options > Ignore Empty Ports should remove that warning when the printer isn’t powered on.

1 Like

At first it did not help but it seemed like it was because I had Serial Port as Auto. I changed this to /dev/ttyS0 in my case and did as you suggested and no I avoid the warning every 20 seconds
Thank you, Thank you, Thank you

The error message you've highlighted is slightly different, and appears when you attempt to connect and it fails. I suspect you have a plugin or app or something that keeps trying to connect to the printer.

When you check auto-connect on startup OctoPrint will try once, then gives up. It doesn't keep trying, that's something else triggering that. Test in safe mode and test with any 3rd party apps on smartphones, touchscreens etc. disabled.

1 Like

Okay, now I've found what's causing this message for me and thank you so much for giving me a hint that it's a plugin, I went through my plugins one more time and have found what's causing it, it turned out to be a plugin I use called SimplyPrint.
I want to thank you for helping me find the cause of my little dilemma, Thank you all

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.