No serial port found, are you sure your printer is physically connected and supported? message appear after installing octoprint with Docker

First of all im totally new with Docker i just made some steps that i colleague told me.Till this day i have been using octopi without any problem, i have a raspberry 3 connected to my 3d printer (ender3 V2).

Well, i decided to start using home assistant so i started to use docker to have in the same device octopi and home-assistant. But now when i try to connect to my 3dprinter in the octoprint navegator appears to me the next message: "No serial port found, are you sure your printer is physically connected and supported?"
This is really strange for me because as i said i have been using the octoprint for almost 2 years without any problem and the tipycal problem with the data cable it seems to be a no possible reason.

What did you already try to solve it?

Btw, i tried other cables but i had the same result and also other usb ports to clarify my selve that this was not the problem.
I also took some logs via ssh from the raspi.
Using this command: dmesg | tail

[ 296.432856] usb 1-1.5: ch341-uart converter now attached to ttyUSB0 [ 549.697978] usb 1-1.5: USB disconnect, device number 7 [ 549.698720] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0 [ 549.698834] ch341 1-1.5:1.0: device disconnected [ 563.565031] usb 1-1.3: new full-speed USB device number 8 using dwc_otg [ 563.698014] usb 1-1.3: New USB device found, idVendor=1a86, idProduct=7523, bcdDevice= 2.64 [ 563.698050] usb 1-1.3: New USB device strings: Mfr=0, Product=2, SerialNumber=0 [ 563.698066] usb 1-1.3: Product: USB Serial [ 563.699065] ch341 1-1.3:1.0: ch341-uart converter detected [ 563.701475] usb 1-1.3: ch341-uart converter now attached to ttyUSB0

Additional information about your setup

As i said i installed ( i dont know if this is the correct word to use) octoprint with docker, using this yaml file:

version: '3'
container_name: homeassistant
image: homeassistant/home-assistant:latest
- ./homeassistant:/config
- "8123:8123"
restart: always

container_name: octoprint
image: octoprint/octoprint:latest
- "5000:5000"
- ./octoprint:/octoprint
restart: always (31.9 KB)

This is my first post, so sry if i forgot some information.

BR and thank you in advance

In your docker-compose.yaml you should have under devices a line like this:

      - /dev/ttyUSB0:/dev/ttyUSB0

OMG thank you so much this was the solution

1 Like