No Serial Port Found! WTF

What is the problem?

One day to the next my Ocotprint throws an error that it can not find a serial port and will not connect to my printer, my entire setup has worked 100% prior to all this, only change that would have been recent is the FW update PRUSA put out not long ago. Ive had issues since, crash detection went on the fritz, had to turn that off and now this imo.

What did you already try to solve it?

Rebooted everything, new power strip/surge protector. After lots of hair pulling, I swapped with another Pi4 b that I have and the issue is identical. Reason I tried this is bc it did this about a week ago, unplugged the printer moved it over into another USB slot on the Pi and it worked. So i assumed that particular USB slot shit the bed and it is what it is. Here we are A week or so later and the problem is back with a vengeance. I have ordered a new USB C PS from Raspberry as the one im using is an AMAZON purchase but is a PS style not cell phone or vape mod style not "name" brand. When I got it to work the first go around to check connectivity between the Printer and the Pi itself, I chose to update the firmware using a laptop with Prusaslicer. That went well. This time, Prusa Slicer gives me an error that it can not comm with the printer. Ive turned off and on RPi within the printer, nothing. Everything imo is leading down the road that the damn main board on my PRUSA is f'd but IDK, Im open to any suggestions at this point. If it is the board Im none too impressed, its barley 2 years old and has about 21 days of prints in total. It s all haywire now, luckily I have access to the GUI within the pi to run diag on it if anyone can help me read it, bc its over my head. i did take a screen shot of the first go around that I was able to match up with the FAQ page the error links me to.

Have you tried running in safe mode?

No, but I will (68.5 KB)

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

What kind of hardware precisely, OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
FW 3.1.2
Octoprint 1.9.3
Windows 10 pro
Octoprint is hard wired, no WIFI enabled
Raspberry Pi4 b 2G

consider downgrading the firmware back to the previous version and see if the issue persists? if the issues didn't exist prior to the new firmware and rolling back gets you back into a stable state then it's safe to assume that the issue is the newer version firmware.

Have you checked this?

off uses the USB port, on the internal RPi port

I have not attempted to down grade FW, although this setup did and has worked with the current FW version.The printer will not comm with PRUSA Slicer now in order for me to change FW

I have tried this. No change at all. Its set to off at the moment.

Already checked the USB cable? Maybe it has an issue...

Yeah, I have the original cable the printer came with and a rando cable Ive tried. Both have worked in the past, BUT I plan on heading over to Microcenter today and picking up a new-new USB cable and Im hoping they have the actual Raspberry PS in USB C flavor. Im not waiting until tomorrow for the one I ordered, this is driving me nuts. Ive tried to hook up into it using Pronterface/Printrun although Im not sure Im using it correctly.Seems clean cut but no ports show up and It gets "stuck" on "connecting" off to the right hand column. I have not tried comm with the printer via PRUSA Slicer with the RPi port "ON", is that how I should try this? Ive never had to do that in the past but I don't guess that matters when your chasing issues. Forgot to mention, in the past Ive plugged the printer into my laptop and no Notification would pop up all, lately when I plug in the printer, a Windows Notification pops up and roughly says "unrecognizable USB item that has malfunctioned in the past that is unresponsive"

This is for connecting to uart the way Prusa documented how to connect a zero using the pin header so many years ago. For USB you definitely want that off.

ok, ya its off by default and is off now. I just got back from the store, new Data USB cable, New Raspberry Pi PS USB c type. Hell, I even got a new SD card 16g I read some where that can F things up like this.. IDK :crossed_fingers:

Its official, the USB port on my board took a dump..Safe to assume once I swap out boards all my sheet profiles are going to be lost correct? What a pain.