No stream in Octoprint, but camera is working in console

Camera model

Raspberry Pi Camera Module V2 (IMX219)

What is the problem?

I installed Octopi (New camera stack) via RPI Imager yesterday and I can't get my camera streaming in Octoprint. From console, however, I can.

  • Can confirm that camera works when running libcamera-hello in console
  • It gets listed when running --list-cameras as well

What did you already try to solve it?

Googling and checking config files, should be as recommended.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (148.3 KB)

Additional information about your setup

OctoPrint: 1.9.2.
OctoPi: 1.0.0
Raspberry Pi 4

Webcam feed turns up like this:

Settings view:


I had same problem and solved it.
In my case I had to adjust the Streaming URL to:


This workes, as long as the motion streaming service is running on the raspi.
I needed to setup motion on the raspi beforehand ...

What I have not yet solved is how to get the snapshot / URL for snapshot.
Please give me a ping if you have a solution for that :- )

Greetings from Cologne!

Hi, @Hadenmann

I tried changing hostname for ip and I get the exact same response, adding port 8081 did not resolve to anything. So I am still lost here. But thanks for your tip!