No Video with new camera stack - Logitech USB c310

Camera model

Logitech c310

What is the problem?

No video, no stream, and http:///webcam says Webcam server is not running.

What did you already try to solve it?

Edited the configuration file in /boot/camera-streamer to include OPTIONS="--http-listen="

Logged in via ssh to make sure pi sees camera

Checked logs to make sure camera-streamer has loaded the configuration

Checked to make sure service is running

Tried loading the /webcam endpoint

Logs indicate its still using libcamera configuration, but I haven't any of those cameras setup.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (16 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

  • Octoprint 1.9.3 with new camera stack,
  • OctoPi : Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.5
  • Creality Ender V3 SE with v1.0.4 firmware
  • Chrome on Mac OSX Sonora 14.2.1

What is the result of this? From the looks of the log, the streaming service is running.

The webcam server is currently not running
If you do not have a camera attached, this is normal and can be safely ignored.

Otherwise, if you just started up your Raspberry Pi or just plugged in your camera, please wait a couple of seconds.

If the issue persists, please check the following:

If you have a Raspberry Pi camera, verify that it is properly attached. The ribbon cable can be plugged in the wrong way. Power off your Pi first, do not attempt to attach or detach the Raspberry Pi camera while the Pi is powered!
Your camera might not be configured correctly. Please check the configuration files in /boot/camera-streamer/ and make sure they are correct for your camera. See the configuration documentation for more info.
Log into your Raspberry Pi via SSH. Check if your USB camera is detected by the system via lsusb.
Log into your Raspberry Pi via SSH. Check if your Raspberry Pi camera is detected by the system via libcamera-hello --list-cameras.
If your camera is detected, check what the camera stack is reporting by running journalctl -u camera-streamer\* | pb. You can use the resulting link to view the logs or share them with the community easily. You can also get these logs by downloading a systeminfo bundle from your OctoPrint server.
If all that doesn't help to troubleshoot the issue, you can seek support on the OctoPrint Community Forum or Discord Server. Please provide as much detail as possible, including your camera model and the results of all the troubleshooting points above. Making your post as detailed as possible makes it more likely you'll solve your issue.

I agree it does seem like the service is running but the front end doesn't seem to know it.

( Edited the configuration file in /boot/camera-streamer to include OPTIONS="--http-listen=0.0.0")
That needs to be
With 3 zeroes that is an invalid input and you won't get anything. Also, no spaces between the zeros and periods

That was a typo, I fixed the original post.

Because you did not move or delete libcamera.conf before setting up your Logitech, Camera Streamer assigned your Logitech a different port.

It appears to be working on 8081 and you seem to get successful connections.

Jan 25 09:39:43 octoprint sh[1830]: util/http/http.c: ?: HTTP listening on
Jan 26 07:51:26 octoprint sh[1830]: util/http/http.c: HTTP8081/1: Client connected (fd=4).
Jan 26 07:51:26 octoprint sh[1830]: util/http/http.c: HTTP8081/1: Request 'GET' '/stream' ''
Jan 26 07:51:26 octoprint sh[1830]: util/http/http.c: HTTP8081/0: Client connected (fd=5).

However there are many attempts to open libcamera.conf which keep failing. You may want to remove both configuration files and use the "add-usb-camera" script to add your c310 back in.

Wanted to follow up here. I did as you described and nothing changed so I went back to basics and tested everything. Turns out that the webcam doesn't work anymore. I swapped out another Logitech c270 I use for zoom meetings and it works swimmingly. Thanks for the help.

Glad you got it sorted out.