No web interface after 1.8.3 upgrade

What is the problem?

After upgrading to OctoPrint 1.8.3, my web interface is gone. I have a message saying "The OctoPrint server is currently not running"
It recommends refreshing...

  • waited 5 minutes +, same.
    It says to verify the process is running. I get no results from the command, which indicates (to me) it is not running (command to run is ps -ef | grep -i octoprint | grep -i python.) It just goes to next line.

What did you already try to solve it?

I have fully powered off Pi, and printer, multiple times. Same result.
I have reviewed the log, and found that it complains about a plugin, but is starting in safemode. It then has some unhandled exception.

Have you tried running in safe mode?

According to the log, it is starting in save mode due to failed starts, and then having an unhandled exception.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

pi@octopi:~ $ octoprint systeminfo
-bash: octoprint: command not found

I'm not able to get to the web interface. SSH only. Octoprint not able to run, so not able to export system info. Let me know what files or other info you'd like. I will attach the log.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Printer is SOVOL SV01 connected via USB.
Running OctoPi 0.17.0

Everything has been working great for some time. When I check python version, i'm getting ...
python --version = 2.7.16. python3 --version = 3.7.3

My Pi / Print versions via ssh...

pi@octopi:~ $ ~/oprint/bin/octoprint --version
octoprint, version 1.8.3

pi@octopi:~ $ cat /etc/octopi_version
0.17.0
octoprint.log (13.2 KB)

Please help. :slight_smile: FYI - I am a Patreon supporter.

Worst case, is there a guide or info on how/what to get off of this thing, before I reimage and start clean?

1 Like

Can we see the error in the log please? That's the only way that anyone will know what the problem is. We're not mind readers.

There's a couple of already known common problems people have installing 1.8.3+, most of which we've already figured out a solution for - if you have a log it would confirm the problem.

Message that shows in the browser....

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Community Forum. Please provide your OctoPi and OctoPrint versions as well as your octoprint.log and explain what you already tried and observed as detailed as possible.

Message that shows in the log file that is ATTACHED to my original post....

2022-10-03 22:15:10,622 - octoprint.startup - INFO - ******************************************************************************
2022-10-03 22:15:10,626 - octoprint.startup - INFO - Starting OctoPrint 1.8.3
2022-10-03 22:15:10,627 - octoprint.startup - INFO - Starting in SAFE MODE. Third party plugins will be disabled!
2022-10-03 22:15:10,627 - octoprint.startup - INFO - Reason for safe mode: problem during last startup
2022-10-03 22:15:10,627 - octoprint.startup - INFO - ******************************************************************************
2022-10-03 22:15:10,978 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity changed from offline to online
2022-10-03 22:15:11,069 - octoprint.util.connectivity.connectivity_checker - INFO - Connectivity state is currently: online
2022-10-03 22:15:11,069 - octoprint.util.connectivity.connectivity_checker - INFO - Connecting to 1.1.1.1:53 is working
2022-10-03 22:15:11,069 - octoprint.util.connectivity.connectivity_checker - INFO - Resolving octoprint.org is working
2022-10-03 22:15:11,669 - octoprint.startup - INFO - Blacklist processing done, adding 3 blacklisted plugin versions: roomtemp (any), GcodeEditor (>=0.1.1,<=0.2.8), gcodeleveling (>=0.1.0,<=0.1.1)
2022-10-03 22:15:11,676 - octoprint.plugin.core - INFO - Loading plugins from /home/pi/oprint/lib/python3.7/site-packages/octoprint/plugins, /home/pi/.octoprint/plugins and installed plugin packages...
2022-10-03 22:15:12,981 - octoprint.plugin.core - ERROR - Could not locate plugin googledrivefiles
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/core.py", line 1188, in _import_plugin_from_module
location, spec = _find_module(module_name)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/core.py", line 45, in _find_module
spec = imp.find_module(name)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/vendor/imp.py", line 288, in find_module
raise ImportError(_ERR_MSG.format(name), name=name)
ImportError: No module named 'octoprint_googledrivefiles'
2022-10-03 22:15:13,068 - octoprint.plugin.core - INFO - Found 25 plugin(s) providing 18 mixin implementations, 38 hook handlers
2022-10-03 22:15:13,097 - octoprint.server.heartbeat - INFO - Starting server heartbeat, 900.0s interval
2022-10-03 22:15:13,106 - octoprint.cli.server - ERROR - Uncaught exception
Traceback (most recent call last):
File "/home/pi/oprint/bin/octoprint", line 8, in
sys.exit(main())
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/init.py", line 936, in main
octo(args=args, prog_name="octoprint", auto_envvar_prefix="OCTOPRINT")
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1130, in call
return self.main(*args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1055, in main
rv = self.invoke(ctx)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1657, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 1404, in invoke
return ctx.invoke(self.callback, **ctx.params)
File "/home/pi/oprint/lib/python3.7/site-packages/click/core.py", line 760, in invoke
return __callback(*args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/click/decorators.py", line 26, in new_func
return f(get_current_context(), *args, **kwargs)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/server.py", line 330, in serve_command
disable_color=no_color,
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/cli/server.py", line 163, in run_server
octoprint_server.run()
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/server/init.py", line 371, in run
self._setup_app(app)
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/server/init.py", line 1466, in _setup_app
from flask_limiter import Limiter
File "/home/pi/oprint/lib/python3.7/site-packages/flask_limiter/init.py", line 4, in
from .errors import RateLimitExceeded
File "/home/pi/oprint/lib/python3.7/site-packages/flask_limiter/errors.py", line 6, in
from .typing import Optional
File "/home/pi/oprint/lib/python3.7/site-packages/flask_limiter/typing.py", line 14, in
from typing_extensions import ParamSpec
ImportError: cannot import name 'ParamSpec' from 'typing_extensions' (/home/pi/oprint/lib/python3.7/site-packages/typing_extensions.py)

I do apologize - I read your post twice and didn't see the log file for some reason. I'll blame it on a lack of sleep recently I think....

Anyway, the error that is there is one that has been seen before - please check my post linked below for details of how to fix the issue. So far we think it's likely to be a pip bug, only affecting those with pip 20.2 for some reason.

No problem. Totally get the lack of sleep bit.

I've tried this, and I get "pip: command not found". I'm typing in (same result with or without sudo)
pip install -U pip

Try using "pip3 install -U pip" then "pip3 install typing-extensions==4.3.0"

The command pip should be linked to pip3 but for some systems it may not be.

First you will need to activate the virtual environment where OctoPrint is installed - in OctoPi (& your install) this would be running source ~/oprint/bin/activate` first, and then running those commands should work OK.

AND... We are BACK! Thank you Charlie!!!

1 Like