No web interface


#1

What is the problem?

When navigating to the web interface, I get a ERR_CONNECTION_REFUSED returned from my browser. This happens on any device, computer or phone.

What did you already try to solve it?
I can ssh into the my pi, see the text "Access OctoPrint from a web browser on your network by navigating to any of:" that list the IP. I can plug an HDMI cable into an see the boot process with it again listing out the IP.

So far I've tried:

A reboot
sudo service octoprint restart
sudo service octoprint stop
sudo service octoprint starts
sudo service haproxy stop
sudo service haproxy start

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Octopi Version: 0.15.1
OctoPrint: 1.3.10
Printer: Powerspec3d Pro

Octoprint.log: https://pastebin.com/fAGtbk1t

Haproxy.log: https://pastebin.com/5xDYNaQJ

I've been using it for a while without any issues and just randomly this issue starts to occur.


#2

for one, you have a power issue that causes it to run at about half speed. This is bad. You need to buy a new power supply for it:

2019-02-08 18:35:01,077 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

Second, the flashsailfish plugin is calling for a library that isn't there:

2019-02-08 18:36:27,892 - octoprint.plugin.core - ERROR - Error loading plugin flashsailfish
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/plugin/core.py", line 847, in _import_plugin
    instance = imp.load_module(key, f, filename, description)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_flashsailfish/__init__.py", line 13, in <module>
    import xmltodict
ImportError: No module named xmltodict

Looks like maybe you disabled that?

Anyhow, it appears to be running. ssh to the machine and see if the web servers are running locally:

curl http://localhost:5000
curl http://localhost:80

The output doesn't really matter, it should just be a pile of HTML, not a connection error.


#3

Hey, thank you for responding!

I change out the power supply. I'll have to test the old one as it's not a typical psu.
I uninstalled the flashsailfish plugin through the terminal. There's no loss there since I never used it anyway.

I ran the two command provided and the one with port 80 returned:

curl: (7) Failed to connect to localhost port 80: Connection refused

While port 5000, returned HTML.


#4

great, that matches your logs too, which is octoprint is running, but for some reason haproxy is barfing.


#5

Should I just go ahead and rebuild the Pi?


#6

It sounds like haproxy isn't happy.

I'd try starting from scratch with these instructions.


#7

I'm more curious what happened, but it's up to you. If you have files you've modified, let us know and we can help troubleshoot.

Or just kill it.


#8

I ended up killing it, I needed it do some printing as I use it to turn on the printer through a relay and by passing it would've taken much longer since I made the wires to length.

On the power supply note, it's perfectly fine. I ran it through a load calibration test and it's on par with the specs it was built for.

I did try to clone the entire sd card by mounting the Linux partition to understand why it stopped working but between my sd card dock continually disconnecting, throwing it out and buying a new dock, I just created a new build.

Thanks for everyone help though!