No wired DHCP on new install


#1

Hi all,

Ive just created a new image of octopi 0.14 on a microSD card. Ive plugged it into a new raspberry pi 3. I dont want to use wifi - the signal is too weak in the target location.

I plugged into a wired connection but im not getting a dhcp address assigned. Ive seen this before but somehow got it fixed.

Ive tried different cables and sockets, both of which are known to work with other devices.

Am i mis reading this or should octopi 0.14 support wired dhcp out of the box ?
Thanks,
Kev


#2

OctoPi 0.14 should support wired DHCP out of the box.


#3

Using another computer log into your routers interface by going too 192.168.0.1 and do some investigating, this will at least help you to determine that it is indeed the octopi that's the issue This post should help you do so. https://discourse.octoprint.org/t/finding-the-pis-ip-address/844 Also search "octopi dhcpcd" on google you may find previous issues similar to this


#4

Solved. Something to do with the imaging process. The boot was hanging, while trying to register the ethernet device. So, pi was never requesting an IP address.

Fix was to simply re-image.

Kev