Not able to connect to Octoprint from my computer

What is the problem?
I am unable to connect to Octoprint on my Raspberry Pi 4b using http://octopi.local. Also unable to ssh into it. I followed the instructions here.

What did you already try to solve it?

  1. Reinstalled multiple times
  2. Researched the issue on this forum and Reddit. Including the Wifi megathread. Nothing seemed to help.
  3. Installed Raspbian to ensure that it was not a hardware issue. Raspbian was able to connect to my Wifi fine (albeit taking a slightly long time to connect) and I was able to ssh into it using the IP.
  4. Tried directly editing octopi-wpa-supplicant.txt with my wifi settings.

Logs (syslog, dmesg, ... no logs, no support)
I don't have any logs because I can't figure out how to produce them in this instance.

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)
It is a resident network for the apartment I live in. I doubt they have these kinds of connections blocked because ssh was not blocked and they are really lazy with tech and maintenance.

The Octopi image is on a Raspberry Pi 4b with Octopi installed from Imager, I am trying to connect from a desktop PC on the same network which uses Arch Linux. I also tried connecting with my phone, which uses LineageOS.

Here is my wifi supplicant file in case there are any issues (ssid and password obviously not the actual ones):


## WPA/WPA2 secured

## Open/unsecured
#  ssid="put SSID here"
#  key_mgmt=NONE

## WEP "secured"
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see:
#country=GB # United Kingdom
#country=CA # Canada
#country=DE # Germany
#country=FR # France
country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

Additional notes:

  1. My Raspberry Pi is connected to a 5v buck converter connected to my Ender3 power supply using the wires from the original plug that it came with.
  2. I plugged it into HDMI to verify that it is working. It indeed is. When I power it on, it goes through the usual Linux startup process and then I get the following message (note the absence of an address):
You may now open a web browser on your local network and navigate to any of the following addresses to access OctoPrint:

https is also available, with a self-signed certificate.
  1. When I connected it directly to my computer via ethernet, it did generate an address, but when I tried to connect to it via my personal computer, it timed out every time.

Was this after upgrading/installing Octopi 1.0.0 & Octoprint 1.8.6 image? Since installing this image,I had to ssh in via ethernet even when using the configuration tool in the imager utility to configure the wifi. raspi-config allowed configuring wifi and successfully connected but the web interface won't load on either connection. I have 2 other R-pi's in my environment that work flawlessly on previous version of octopi. I will be going back if I can.

I ended up just installing Octoprint via Raspbian instead of the Octopi image and now it is working.

Just thought I'd chime in and say I had the same (or maybe similar?) issue using latest version of octopi installed via raspberry pi imager. I found that if I plugged a monitor and keyboard into the raspi it appeared to be working fine and gave an ip address to connect to. But when I tried to accessing it on my pc it "couldn't reach this page". I looked at the clients connected to my router and it was listed in there as connected - just couldn't ping the ip address or go to the webUI

I haven't tried installing via Raspbian yet to see if it'll work. I did find that plugging it in via ethernet cable worked - just not via wifi.

Hello @troyhowarth !

So do it please. So the OP wrote it twice.

And BTW:

Please always us the actual version number. "Latest" can be very different in a short time.

1 Like

I recently had the same problem, after a lot of troubleshooting i found out that the Raspberry Pi didn't like the SD card is was using, after switching it with a different one it worked immediately. I highly recommend you try this too.