Not able to see camera stream on octopi

Camera model
Raspberry pi module model G
What is the problem?
Not able to get camera stream working on octopi.
What did you already try to solve it?
I tested that the camera is working properly on the raspberry itself, I am able to take and see pictures from it. I enabled the camera on the pi but I only have the legacy option. When legacy is disable, nothing is detected with vcgencmd get_camera but I am able to take picture. When legacy is enable I see the cam detected and can still take pictures. I tried to run haproxy and looked at the file but did not change anything. I ran the upgrade and update command. I changed the octopi.txt file for my camea. I changed the URL adress for the stream and snapshot to different things. To be honest maybe I tried too many things I've been looking at solution for 3 days now. (93.5 KB)

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
I attached the system info downloaded from octoprint, not sure if it's the best way.
Additional information about your setup (OctoPrint version, OctoPi version, ...)

What's model G?

This one Raspberry Pi Camera (G) with Fisheye Lens