Not able to update Octoprint or install plugins

What is the problem?

I recently updated my raspberry Pi to the latest Octopi 0.18.0 with the included Octoprint (1.5.2) since I had a very old version before. But when I log in Octoprint it says:
"There are updates available for the following components:

  • OctoPrint: 1.6.1
  • File Check Plugin: 2021.2.23
  • Firmware Check Plugin: 2021.2.4"

But when I try to update directly from Octoprint I only get the error:
"The update could not be started. Is it already active? Please consult octoprint.log for details."

So to conclude the problem, It is not possible to update from Octoprint and also not possible to install plugins.

What did you already try to solve it?

  • I have tried to change the power-supply to a more powerful one since I got the 5V under-voltage error message also. The under-voltage message have disappeared but I still cannot update.
  • I have also taped the 5V pin from the Pi to the printer after reading there is known issues with back-powering on the Creality printers.
  • I have also tried the most obvious solutions as to reboot the Pi, change browser, safe-mode.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (1.0 MB)
serial.log (148 Bytes)

Additional information about your setup

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1200
env.hardware.ram: 915722240
env.os.bits: 32 linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x50005
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.2

Hello @Lelle91 !

You have an under voltage and throttling issue.
You should look for a better power supply.

For real? I just changed the power supply to a stronger one, I power the Pi with a micro USB power supply (micro USB cable and a Samsung S9 phone adapter.) The adapter is rated for 5.0 V 2.0 A and thought it would be enough?

For a RasPi 3B+ a power supply (not charger) with at least 2.5A is recommended.

Updates are disabled as long issues mentioned before persist.

1 Like

Some devices expect a charger and some expect a proper power supply. If you use a charger when the device expects a power supply, there can be issues.

I totally missed the recommended 2.5 A. Thanks so much for the information. :slight_smile:

I just ordered a power supply specified for raspberry Pi 3 with 5.1 V and 2.5 A output. Hopefully this fixes everything. ^^ Will see tomorrow when it arrives.


Hi again!
Just want to say that it worked! :smiley: Everything works flawlessly now and I could both update and installing plugins. Thanks for the help. :slight_smile: