Not communicating with bluetooth Outlet


What is the problem?
I have been using octoprint for about two years now and my system was set up with a Bluetooth outlet that allowed me to turn on and off my printer without having to be there. I have a close friend that has one arm that wanted me to get him set up for 3D printing. So I got all the supplies to set up octoprint and all was running smoothly until I got to the Bluetooth outlet. I configured the folders, commands and tested the system in SSH and it worked. For some reason I went to set up the System Command Editor with the commands, it failed every time. At first the settings window would close before I could save the setting but then when I finally had the settings saved, the commands failed every time. This works flawlessly on my system and have been running it for well over a year now. I set his up the exact same way although he has the most up to date version available for octoprint. Every time I run the command in SSH it works but within octoprint it says that the command does not exist.

I tried to add screenshots of the problems but this forum will only allow me to post one picture in this post.
*What did you already try to solve it?
I reformatted the entire system and reinstalled everything.
I attempted to place the configuration file for the Bluetooth outlet in a different folder.

Additional information about your setup

Thank you in advance.




The error message says it all. It can't find your python script. Add a full path to your script and see if that's happy.

Personally, I might consider surrounding the MAC address on that command line in double quotes.