Not queuing T2, that tool doesn't exist - Error

What is the problem?

A few weeks ago my Geeetech A30T was working fine with Cura + Octopi, but now it gives the "Not queuing T2, that tool doesn't exist according to the printer profile or was reported as invalid by the firmware. Make sure your printer profile is set up correctly." Error

What did you already try to solve it?

I enabled the setting "extruders share heater" in Cura.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Nope, same error. (34.6 KB)

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I think I attached it, I will edit and add it if it didn't work correctly.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version - 1.6.1
OctoPi version - 0.18.0
printer - Geeetech A30T
firmware - Not sure, but I bought it after it received its latest update
browser - Chrome (worked fine for months for Octopi)
operating system - Windows 10, latest updates

Thanks for any help.

Please enable Serial Logging, then do all the steps until the error comes up once again. Then add the serial.log here. You can enable it via Settings > Serial Connection > Log communication to serial.log
The log is at ~/.octoprint/logs


You said you enabled extruders share heater but you didn't mention how many extruders are configured. You should have at least 3 and possibly more as this printer support virtual extruders.

1 Like (59.3 KB)
That is with the serial.log enabled. Idk if it is enough info, since I pressed emergency stop. Whenever I press cancel, my Octoprint likes to let the nozzle keep heating up for a while , I assume until it reaches the desired temp in the Gcode. But if it needs to run longer I can let it do so.

Sorry, I tried filling out all the info that it asked for in the OP. There are 3 extruders and 1 nozzle, and all 3 are enabled in Cura when saving the file. They all have matching settings too, the same setting's for everything

Sorry if I wasn't clear. How many extruders and how many nozzles has to be set in two places, your slicer (Cura) and the OctoPrint printer profile. On OctoPrint go to Settings, Printer Profiles, select the active profile, click edit, click Hotend & extruder, and either take a screenshot or tell us what you have in each of the fields.

1 Like

The Gcode command to set the temperature of the nozzle is either M104 or M109. M104 sets the desired temperature and continues, M109 set the desired temperature and waits. If you cancel a print when an M109 is in progress, it will continue until that command is complete.

When we asked for the serial log, we want it enabled and then we want you to repeat the experiment that causes the "Not queuing T2" error. Then we want you to upload the bundle.

1 Like

I think you've been a bit fast hitting emergency off, it won't waste that much energy to let it go through once. As it is, there is just one instance of "Not queuing T2":

2021-07-08 19:54:10,894 - Changing monitoring state from "Starting" to "Printing"
2021-07-08 19:54:10,902 - Warn: Not queuing T2, that tool doesn't exist according to the printer profile or was reported as invalid by the firmware. Make sure your printer profile is set up correctly.
2021-07-08 19:54:10,905 - Send: N1 M140 S35*82
2021-07-08 19:54:10,932 - Recv: ok T:26.3 /0.0 B:29.6 /35.0 T0:26.3 /0.0 T1:88.2 /0.0 T2:107.7 /0.0 F:0 R:100 @:0 B@:0
2021-07-08 19:54:10,937 - Recv: ok
1 Like (63.8 KB)
I stopped it right before it stated printing this time so hopefully this is enough. If I need it to start extruding material please let me know, sorry about the useless log earlier.

You are right, for some reason this setting has been reverted. It is back to 1 and it shouldn't be. Lemme double check some things and then try a print I think this is the solution but I want to confirm real quick.

Edit : that was definitely the fix and it was as simple as clicked the shared nozzle within Octoprint as well. I guess since Cura got that new setting, Octoprint also had to change around its extruders setting. Thanks a lot for the help.