Not Secure message from MacOS 10.13.4


#1

45

I just upgraded to MacOS 10.13.4 High Sierra. I am now getting this "Not Secure" message in the URL window of Safari. I also upgraded OctoPrint to 1.3.7rc4 on the same day so I am not sure who is causing this or what it really means. I would tend to blame Apple before Gina! :slight_smile:

Has anyone else seen this?

OctoPrint 1.3.7rc4 running on OctoPi 0.14.0


#2

It's expected. "with ... macOS 10.13.4, Safari also checks if a website that asks you to enter password ... is not secure because it's unencrypted."

Basically, you're using a password but not using https on OctoPrint. Using https with a real cert would make OctoPrint installs much more complicated.


#3

what @tedder42 said.

Also, this would be something to be more concerned about if you were browsing the internet and ran across it. In this case, you are accessing something on your Local network, so unless you've installed something nasty on your Pi, it's not much to worry about.