Not starting after update to 1.3.11 - psutil error

Hi,
I've been using octoprint for quite a while now, but I have a problem after updating to 1.3.11. My server is not starting anymore. Manual starting the server returns this error:

pkg_resources.DistributionNotFound: The 'psutil<5.5,>=5.4.6' distribution was not found and is required by OctoPrint

But when updating Octoprint by hand I get no error regarding psutils:

Requirement already satisfied: psutil<5.7,>=5.6.1 in /usr/local/lib/python2.7/dist-packages

Do you have any ideas why it is not working? I love this piece of software and do not want to print without it!
Regards
Joshua

Read what you posted carefully, noting the difference in version requirements for psutil. It looks like OctoPrint wanted something between 5.4.5 and 5.5 and failed to find one. In your attempt to pip install psutil, it appears to have pulled something between 5.6.1 and 5.7 which is a different range.

You didn't indicate whether or not you ran this command manually while activated like this:

source ~/oprint/bin/activate

This is the virtual environment within which OctoPrint runs. (There is a global space which might have different modules/versions in it but that's different.)

Try:

source ~/oprint/bin/activate
pip freeze | grep psutil
#  psutil==5.4.8

As you can see, my own installed version is within that first range and that's what you're after.

Hi
I'm not running octopi in a venv. I downgraded psutils to 5.4.8 but this resulted in pkginfo to be the wrong version. After downgrading it to a suitable version the server started but crashed due to an http server error.
I downgraded octoprint to 1.3.9 and everything runs again, I will reconfigure a new system sometime down the road and till then I'll stick to this version, my installation is not open to the internet, so I have no problems with running a slightly older version.

Thank you for your help! This community is just great!

You really really should to avoid these kind of dependency nightmares. Non venv based setups shouldn't be considered supported in any way.

ETA Also: OctoPrint. Not OctoPi.