Nozzle randomly stops every 30 seconds to 1 minute on perimeters

What is the problem?

When printing from Octoprint the nozzle/build plate stops moving for a few seconds randomly for 4-6 seconds. I decided to let it print than after a while my main board(not the LCD) started making an alarm noise. I get a weird message in the terminal screenshot included.Screenshot 2020-12-15 202643

What did you already try to solve it?

I have tried using different USB cables,printing off an SD card unconnected from Octoprint(that worked), and re-installing Octopi.

Have you tried running in safe mode?

I have tried safe mode.

Did running in safe mode solve the problem?

It didn't solve the issue because didn't install plugins on the new image.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)
Here are my logs. octoprint.log (1.7 MB) serial.log (296 Bytes)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am running an SKR Mini E3 v1.2 and raspberry pi 4b 2gb of ram with a fresh install of Octopi on an ender 3.

I have also tried re-flashing marlin.

You should still be able to print files in safe mode. When you have a problem printing in normal mode, switch to safe mode and print again. If the problem goes away in safe mode, then the problem is in one of the user installed plugins. If the problem continues in safe mode, we need to know that, you can post logs from the safe mode session, and we will try to get to the bottom of it.

Also for future reference, the serial.log needs to be enabled before it will include any useful information. Also note that each piece of blue text is a link that will give you additional useful information.

Here are the files from safe mode. It didn't fix the issue. This is serial.log serial.log (2.9 MB) this is octoprint.log. I had to cut part from overnight because the file was to big so it is just the files from today in safe mode. It was just a lot of the tornado warnings that continue in the part I kept. octoprint.log (845.9 KB)

I wonder if all those tornado warnings are causing the hiccup due to the high level of logging.

Maybe, after some time being idle my board started making an alarm noise so maybe I have a firmware issue. I am not sure they are related. I will look into the tornado warnings and leave my printer running disconnected from octoprint.

2020-12-16 17:43:27,700 - octoprint.startup - INFO - Starting OctoPrint 1.3.12

What's with the old version?

To start, upgrade to the latest version of OctoPrint, you are on 1.3.12 (over a year old) and the latest is 1.5.2. May not make a difference, but it will rule out the 100s of bugs that have been fixed in that time, and you'll get some cool new features.

I thought the Octopi image would be up to date so I didn't worry about it. I tried updating and it didn't help.

I found this thread about a tornado warning I trying was flow the instructions they linked because I am using a netgear router but I couldn't figre out where to put the .htm file.

I got rid of the tornado warnings by removing netgear software from my computer that the requests where coming from. It wasn't anything I ever used anyway so it was no big deal. The tornado warnings stopped but the issue persists. Here is the new log. octoprint(1).log (26.9 KB)

There's only a few dozen of these in the log:

2020-12-17 02:31:28,754 - octoprint.util.comm - INFO - Communication timeout while printing, trying to trigger response from printer.

I don't believe they are normal and may be the cause of your random stops.

Continuing the discussion from Nozzle randomly stops every 30 seconds to 1 minute on perimeters:

I had the same problem with my Ender 3 fitted with a BTT mini E3 V2 Board.
I resolved the problem by changing the serial port allocation with in marlin V2.

The serial setup in configuration.h file changed to


#define SERIAL_PORT -1


  • Select a secondary serial port on the board to use for communication with the host.

  • :[-1, 0, 1, 2, 3, 4, 5, 6, 7]


#define SERIAL_PORT_2 2

Since this change I have had no comms problems.

I will have to try that.

That worked! Thanks for all of the help from everyone but specifically @b-morgan and @Bill.b1.
I was able to print a successful benchy.