Octo on RPi 4b Crashing

What is the problem?

Pi will crash and server becomes unresponsive whether it is printing or just sitting idle.

What did you already try to solve it?

Tested power supply voltage, getting 5.19v via the 2/6 pins.

Tried reflashing octo to SD Card in case it was a bad OS flash.

Tried SSH, after it crashes it doesn’t show online to be able to access any files.

Tried changing firmware on printer itself since it was running stock S1 Plus firmware, tried newest firmware on creality’s site plus custom firmware linked below.

Have you tried running in safe mode?

Yes, still crashes and doesn’t let me ssh in or pull it up on a web interface.

Did running in safe mode solve the problem?

No

Systeminfo Bundle

Doesn’t have info prior to crashing besides the plugin info, posting from mobile so will update with what I can once I am on my pc and have the files.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... Latest Stable Octoprint version,S1 plus, updated firmware to ThomasTako’s here (Releases · ThomasToka/MarlinFirmware · GitHub) , rpi 4b, tried opera and chrome, Windows for my pc. as much data as possible

Just to be sure - how do you know it crashed?
Does the print freeze when it happens or is the pi just not reachable via wifi?

Had the same thing happen today after moving my OctoPi SD card from Raspberry 3B+ to 4B. On 3B+ everything works well, on 4B it started loosing WiFi connection + crashing during printing