Octo Pi desktop not accepting password?! (Argon One)

What is the problem?

After adding the desktop to Octo pi, it does not accept my password.

What did you already try to solve it?

I downloaded and installed the LightDM desktop. The pi starts directly to it. However the login keeps giving me the "incorrect password" This is the same password that I've used for everything I've done so far including adding the desktop. When this happened on my original install, I wiped the SD card, and reinstalled OctoPi. Will I have to to this again? I left user name as "pi".

Have you tried running in safe mode and if so did it solve the issue?

As I understand it, Safe mode related to OctoPrint whereas I'm trying to solve OctoPi OS problems.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Have you tried the standard RasPi login/password (pi/raspberry - if you did not already changed it)?

1 Like

Yep. I did not change the pi login, only the password.

Just to be clear - you changed the password by running passwd or similar? (Can't remember the exact command). It's possible to access the right files from another Pi/Linux box, to reset the password I believe.

1 Like

I changed my password on the Pi by accessing the config with "sudo raspi-config".

See Forgotten username and password to SSH into Pi

1 Like

Hey :slight_smile:

Idea 1 :
My feeling guts : keyboard map.
Is it possible that you have used raspi-config with, say, EN_US (Qwerty keyboard) and now you're login in the graphical interface with a different kmap like FR_FR (Azerty keyboard) ?

Idea 2 :
Can you hit "CRTL+ALT+2" to reach a command line and try your password ? If "2" doesn't show you a terminal login, try a number between 1 and 6.


This might be a thing!
When I was trying to enter the download address for the Argon 1 fan control app entering:

curl https://download.argon40.com/argonone-setup-libreelec.sh | bash

All the letters were correct except the " | " which resulted in a " ~ ". I couldn't figure out what that was. I thought it might be my Logitech wireless keyboard so I tried swapping keyboards including a USB and that did not work. However, in all my applications the vertical line key is correct.

I assume this means the Octo Pi defaulted to a different "map" in the setup? How would I solve that?

First of all, I think you need to get a session on your Pi.

I'd try to connect via SSH, or via the standard terminal (the CTRL+ALT+2 above). You must connect as the Pi user, then sudo -i to get your hand on the root account. Then you'll have to launch raspi-config and look at the localization submenu to configure the correct map.

If you entered a strong password in a different keymap, use the "login:" prompt to try to type your password (instead of "pi" or "root"). When you find the right keyboard keys for your password, log-in and reconfigure the keymap. Then, update pi's password either with the command passwd or with raspi-config.

If nothing works, you may want to take the SD Card out of the Pi and put it in an other computer. The drive "boot" will appear. Inside, create a simple file called octopi-password.txt with a single line : a new (simple) password. Then, put the card back in the Pi, boot and (hopefully) enjoy !

Keep going :wink:

Thanks for your efforts. Nothing worked. I'm reinstalling Octopi on the sd card. When I get to "raspi-config" what should I be looking at to avoid this. (It's has happened twice now.) What would be my keyboard localization map for US-English?

Arf, sad to hear ! I hope you did lose not much than time ? :slight_smile:

As soon as you have a new octopi image running, just try to type on your keyboard. If characters are not what you typed, then you have to change your keymap.

The default keymap, according to my local install of Octopi, is already a "gb" (Great Britain keyboard). You probably want to try with letters from your country there. Mine would read "fr" but I never modified my Octopi since I only use it through SSH (which doesn't really use the keymap from the octopi, but the keymap from ma laptop) :wink:

Usually, raspi-config should do the trick : sudo raspi-config then in menu "4 - Localization Options" you'll have a submenu "3 - Change keyboard layout". For un unknown reason, it gives me nothing on my Pi.

I may need more time if I have to make big tests, if the edition of /etc/default/keyboard doesn't help you. During that time, I'd advise you to pick a password that you can actually type, whatever the keymap is.

But hopefully, editing the file will help :slight_smile:


Wow! "Change keyboard layout" is several pages of options getting into specific key functions. I've never had to do this and was pretty uncertain of the correct choices. Anyway, searching through I found another thread on all this. Desktop issue with startx not working I followed the solution/instructions below,

sudo /home/pi/scripts/install-desktop
sudo apt-get -y install xinit

and now everything seems to be working. "sudo startx" brings up the desktop.

Now I have access to the Raspberry Pi desktop.
Further questions:

  1. OctoPi said to install the Lightdm desktop. I assume that is different then the RP desktop, and that "Light" is as in minimal? Which would be better and how would I install it to be the desktop should I wish to do so?

  2. I wanted a desktop so I could easily install the power button and fan functions for my Argon1 case. if I do this, will they function when I'm not running the desktop?

I had to Google to discover what Argon One is, so I'll try to be more useful than before :wink:

To other : HELP NEEDED :slight_smile:

I can bring you an answer for the question 1. LightDM is what we call in the Linux family a "desktop manager". There quite a lot of them : KDE looks like Windows; Gnome, more like Mac. LightDM ? As you guessed it, it's a light one. And it's better, on a raspberry pi, to keep it very light. If you have to many things happening on your computer (i.e. your raspi), the communication with the printer might become chaotic, and you'll have bad result on your print. That's probably why, to be honest, I wouldn't run a desktop manager on Octopi… unless I have a good reason, like you have.

For the second question, I guess you'll have to test. Half of the programs that you'll launch from the GUI (Graphical User Interface) are actually ran in the background, so if you quit the GUI you'll be okay. But the other half are programs that will stop as soon as your GUI is stopped.

I've checked a bit on Google. It is not clear to me that you need the graphical interface to actually run a software for Argon 1. Is it possible that you're installing the GUI just to install the Argon One tools ?

I feel like you don't need to install the GUI. You just have to type :
curl https://download.argon40.com/argon1.sh | bash

Then, edit the file /boot/config.txt to enter two lines at the very end:

Then reboot the Pi. It seems that Argon One has tooling running as a service (called a Daemon in Linux world ;)) that does not need a Graphical Interface. If you want to configure your buttons, you can edit "/etc/argononed.conf" and either reboot or type systemctl restart argononed.

(again, I say so after reading a few lines on Internet, just so that you can play a bit. Maybe you can add the word "Argon One" in the title of this forum thread so that experienced player join us in the game ?)

Cheers !

Thanks again for your effort. Even researching the case. :smiley:
I guess I understood the desktop thing correctly, and I did think I needed a desktop to get the argon software running. As for having the desktop on the OctoPi SD, I have to start it (sudo startx) to use it. I believe there is no real penalty if it's not running while octopi is running? If so, I'd sooner just leave it. I do have another SD card set up with standard RPi OS and apps, so can just swap it when I want to play with that.

I'll edit the config.txt file as suggested and hopefully that will get the fan working as desired. When I originally built the Pi the fan was like a jackhammer. Labist replaced it with a "quiet" version that was like a hammer drill. The Argon1 has excellent passive cooling, and the quiet fan only started when I lowered the start temp to verify it worked. However, the pi gets hotter in the room with the printer so I want to be sure fan cooling is working.

Edited as suggested.

1 Like

Mornin' :slight_smile:

You're right by saying that when you don't sudo startx, the GUI will not impact your Octopi installation and print – except if there's a very nasty bug but to be honest, I'd be very surprised ;). So yes, just leave it and play with it if/when needed; we're kind in a phase where we try to build the minimal setup for your Argon One, what happens next is just bonus for you as a user :slight_smile:

And by the way : thanks for leading me to the Argon One. It was a totally unknown thing to me before our exchange. I'm still having the Labists hammers in the room :smiley:

Cheers !