Octo pi Not conecting to wifi or octopi.local

#1

First time posting so be nice please.

I have a pi 3b+ and have downloaded and flashed octoprint 0.16. I edited my wifi ssd (no password on my network) just like the read me said in theoctopi-wpa-supplicant.txt. I uncommitted the WiFi country and the correct WiFi settings. I did this VSC. I did this twice.

I am on mac.

When I plugged my pi in but when I go to octopi.local there is no connection. I used a hdmi cord and can see no urls under
"You may use a web browser on a local network...."

I plugged my pi into a Ethernet cable and I see 192.168.0.22 and a IPv6 address.

If I go to 192.168.0.22 it is the octo print set up.

Why does octopi.local not work and why does it not work over wifi?

Any help is great.

#2

Leave the Ethernet cable in there while you're troubleshooting this.

Do a remote ssh pi@octopi.local session (password raspberry). Run ifconfig and see what's going on with the wlan0 adapter. It probably isn't connected to your wifi zone, doesn't have an IPv4 address allocated to it and doesn't have the RUNNING flag in that paragraph.

The guess would be that the work you did to edit your /boot/octopi-wpa-supplicant.txt wasn't happy somehow.

A troubleshooter I wrote.

1 Like
#3

Ok, thanks. I will do the ssh thing in a bit.

here is my octopi-WPA-supplicant.txt file for you to take a look at. REDACTEDLINK

My wifi ssid is "Black" and I am in the USA. I have no other wifis near me other than my printer. It is not hidden. 07%20PM

Thanks

#4

I did the ssh thing and got all 0's

19%20PM

Can you help?

#5

Line 32. You removed the comment characters (##) in front of the comment "Open/Unsecured" no doubt causing the file parsing to fail.

Put the comment back and try again.

#6

Thanks so much. fixed