Octo4a layer shift and crash on large files

What is the problem?

Octo4a is having layer shift when trying to print a large gcode file (175MB)

What did you already try to solve it?

I uninstalled plugins and tried a completely fresh install, it layer shifted and completely crashed with the nozzle and bed still on and the printer disconnected from Octo4a

Have you tried running in safe mode?

no, but this was a fresh install

Systeminfo Bundle

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/100.0.4896.75 Safari/537.36 Edg/100.0.1185.36
connectivity.connection_ok: True
connectivity.enabled: False
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: unknown
env.hardware.freq: unknown
env.hardware.ram: unknown
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.python.pip: 20.3.4
env.python.version: 3.9.5
env.python.virtualenv: False
octoprint.safe_mode: False
octoprint.version: 1.7.3
systeminfo.generator: zipapi


Additional information about your setup

octoprint (1).log (76.7 KB)

Layer shifts on very detailed prints are often caused by stutters.
The printer stutters if you print faster than it can process the moves or faster than the gcode can be transmitted via usb.

Depending on whether your printers firmware supports arcs you can try to use the arc welder plugin either in octoprint or check if there is a plugin available for your slicer (cura for example got it).
How effectively the load can be reduced for your printer with arcs depends on the model.
For example it would help the most for a cylinder.

I can't help you with the crashes tho.
Since it crashes on large files I would guess it runs out of ram. You could try to disable some features like gcode analysis.

Reduce the print speed and/or use arc welder

1 Like

I'm printing with an arc welder file now. It took 43.5 MB out of the file, so I think that'll help. It's a dragon, so lots of arcs.

Appreciate the help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.