OctoDash can’t see my printer/serial port

What is the problem?

I’m unable to ‘see’ my printer from my raspberry pi. The printer is not connected via USB as I had heard backpowering might be an issue. There is an image down the bottom showing how it is connected.

What did you already try to solve it?

I’ve tried

   sudo usermod -a -G tty nymiir


   sudo usermod -a -G dialout nymiir

as suggested by another topic on this site. The first one asked for my password then did nothing. The second one just did nothing.
I have tried looking at the result of


in the last 20 lines, but it just mentions the keyboard and mouse I have plugged in.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20230429184422.zip (63.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version 1.8.7
OctoPi version 1.0.0
Printer: Prusa i3 MK3S+
Firmware: 3.11.0-4955 from Prusa
The browser on the PC is Chrome, on the phone it’s Safari (no idea what the pi has)
Operating system is OctoPi (Debian Bullseye also shows up in the command line sometimes)
Raspberry Pi 4b 2gb
Screen is Smartie Pi Touch 2
Running USB keyboard and mouse
The connection between my printer is as shown in this image, with a longer cable:

You have a Prusa printer. What are you trying to achieve with the GPX plugin?

I have no idea what GPX does. After 4 hours the other night spent trying to fix this problem, I was just trying every suggestion I read, anywhere. One of the things I read said I needed the GPX plug-in to make something else work, so I added it.
Do you think it’s causing the problem?

The GPX plugin is for FlashForge and MakerBot printers. A Prusa i3 MK3S+ doesn't need it and it may very well be causing problems so please uninstall it.

There are numerous Prusa i3 MK3S+ printers being used with OctoPi / OctoPrint and almost all of them are using a USB cable connected to the USB port on the printer. There is one setting that needs to be changed from the control panel connected to the printer and I am unaware of any backpowering issues with Prusa printers.

Since you have chosen to connect the printer and the Raspberry Pi using something other than a normal USB cable, there's a good chance that none of the users that frequently provide help on this forum will have the experience needed to help you troubleshoot that configuration.

The image you provided appears to come from Little Red Toaster Designs so I would suggest that you contact them for help.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.