OctoDash has No Webcam

Camera model
LogiTech C922

What is the problem?
Can't Enable in OctoDash

What did you already try to solve it?
Searched in Google, GIT & YouTube.
Support is mentioned but I find little about config.
Looked in the config.json file but see nothing that seems relevant in there & no entries for a Camera.

Logs (/var/log/webcamd.log)

webcamd.zip (54.4 KB)

octoprint-systeminfo-20230211112435.zip (162.5 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
Version 1.8.6 Pi4 with 8 Gig.

I must be missing something totally & searchs are not helping me.

Created an New OctoPrint Pi yesterday on a New Pi4 with the Official 7" Screen.
Burnt a new card image.
Configured it by loading a backup from my other Pi, (Pi4 Also).

Installed OctoDash & everything works just fine.
Controls, Prints, all good.

What I can't find is any info on getting the Webcam showing on the OctoDash Screen.

Post setting up the new Pi with OctoDash, everything in OctoPrint works fine, including the Webcam within OctoPrint. Time Lapse working as well.

I have the Full Screen & Camera Settings Plugins as well & that's also working as expected.

Try installing my OctoDash Companion plugin to edit the custom actions of your OctoDash install. One of the pulldowns is [!WEBCAM] and will pre-complete the correct url for OctoDash to be able to load the camera stream.

I installed OctoDash Companian from the start, but only took a brief look.

When I choose [!WEBCAM] it fills in the dropdown with this...

Restarting OctoDash I assume is required; but I then see this...

In the Octoprint Setting I have this which is working....

Edit:- I can also see that it's addit this to the config.json file.

					"color": "#dcdde1",
					"command": "[!WEB]http://localhost:5000/plugin/octodashcompanion/webcam",
					"confirm": false,
					"exit": false,
					"icon": "camera"


Got it Working with this.....


Yeah, that works too. I forgot about the need to enable iframe in OctoPrint's settings for the plugin address to work.

That's all working Great Now thanks.
Still haven't enabled the iframe as prints are in progress.

Can you add a bit of a mention of Camera Settings to your GIT?
I saw the Icon showing on the Comanions page, but still struggled to find the simple detail you explained above.

Only other thing; I plan to add a second Cam;
Is that easy to add as a 2nd URL?
Or is there a prefered way.



if my plugin integration is working then it will detect multicam plugin installed and give buttons for switching between the cameras IIRC.