Octolapse errors

What is the problem?

The camera goes into connecting mode when it is idle and only clicks when the head moves into position.
I get an error when that happens, which is every layer.

Using Sony A6000 camera with OctoPrint 1.4.0 running on OctoPi 0.17.0 and octolapse version 0.3.4

What did you already try to solve it?

Tried playing around with snapshot timeout setting, if set to 5000 it does not take an image and gives an error if set to 15000 it does take an image along with an error

My snapshot delay is set to 0.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Following is the error that I get when my snapshot delay is set to 15000, the camera clicks a picture and I still get the following error from octoprint.

Octolapse - Camera Error

snapshot_script_error: The snapshot script failed with the following error message:
*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program (gvfs-gphoto2-volume-monitor) or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.
ERROR: Could not capture image.
ERROR: Could not capture.
*** Error (-53: 'Could not claim the USB device') ***

The snapshot was not found in the expected directory: '/home/pi/.octoprint/data/octolapse/snapshots/28be8e32-d707-4a05-8e3d-ca30e0435e2a/161765a8-fe99-434c-bbd7-f4b935ee8702/testpenstand_0.2mm_PLA_MK3S_1h16m000017.jpg'.

Another type of error that I get is:

Error 1 - snapshot_script_error: The snapshot script failed with the following error message:
*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program (gvfs-gphoto2-volume-monitor) or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.
ERROR: Could not capture image.
ERROR: Could not capture.
*** Error (-53: 'Could not claim the USB device') ***

The snapshot was not found in the expected directory: '/home/pi/.octoprint/data/octolapse/snapshots/96d1cb77-ae24-46aa-8ada-c12813b2257c/161765a8-fe99-434c-bbd7-f4b935ee8702/testpenstand_0.2mm_PLA_MK3S_1h16m000000.jpg'.

Error 2 - snapshot_script_error: The snapshot script failed with the following error message:
*** Error ***
An error occurred in the io-library ('Could not claim the USB device'): Could not claim interface 0 (Device or resource busy). Make sure no other program (gvfs-gphoto2-volume-monitor) or kernel module (such as sdc2xx, stv680, spca50x) is using the device and you have read/write access to the device.
ERROR: Could not capture image.
ERROR: Could not capture.
*** Error (-53: 'Could not claim the USB device') ***

The snapshot was not found in the expected directory: '/home/pi/.octoprint/data/octolapse/snapshots/96d1cb77-ae24-46aa-8ada-c12813b2257c/354def78-9eea-409a-ad23-ee966dfff4ba/testpenstand_0.2mm_PLA_MK3S_1h16m000000.jpg'.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Using prusa Mk3s